Slow sudo execution since snapd update

Hi there,
since the last snapd update my sudo execution is taking ages till the password prompt appears.
When the password isn’t correct it’s taking ages again till the next prompt appears.
Please help guys, this is so annoying.

Some posts on the internet are suggesting to update /etc/hosts in correspondence to the current hostname of the system, but that didn’t help.
Refereing to this post I could try to remove snapd, but on the other hand I don’t want to break my system:smile:

Are there any users experiencing the same issue?

1 Like

Yes, I think I have the same issue. It’s very slow to log in for me after resuming from suspension, and sudo execution is also painfully slow. I’m running Fedora 30 KDE.

Thanks for the link to the bug report! I’ve been trying to figure out what’s been causing this crap.

1 Like

You’re welcome.
Ha! That’s interesting. I’m running Fedora 30 Gnome.

After downgrading snapd like so (in my case)

dnf install snapd-2.38-2.fc30.x86_64 snapd-selinux-2.38-2.fc30.noarch

it’s working properly again. Yay.
PS: don’t forget to restart afterwards.

PPS: if you’d like to ignore snapd temporarily from your usual dnf upgrade process till the package is fixed, you could do this manually like so or via an additional entry in your conf like this:
“exclude=snapd* snap-confige” is the line you should add.


I have the same problem on fedora 30 with gnome.

1 Like

I had the same problem on Fedora 30 with Cinnamon (GNOME). Turned out your solution solved it, thank you! I expect more people to have this issue soon …


@ferb @bramth: welcome to the community! Please go over the introductory posts in #start-here if you’ve not yet had a chance. They include useful information on how to use the platform better/effectively.

If you’ve not yet done so, please do reward @locke by liking their post. It’s Discourse’s version of an “upvote” (also covered in the #start-here posts).

I had this problem before, I edit my resolv.conf and problem solved.

THANK YOU for posting this!!! I was having three issues that were apparently tied to snapd, and I was struggling to understand why they were occurring, but they all took place at the same time:

  • Battery percentage was no longer displaying in top right of screen on toolbar
  • su and sudo would delay for about 15-30 seconds after entering command
  • Login screen would freeze when attempting to login for about 30 seconds

These are now all resolved thanks to this post! :slight_smile:

1 Like

You’re very welcome.
However the maintainer reacted pretty quickly and the update to snapd-2.39.1-1 fixed it.
Seems it was related to revamped SELinux support in snapd.
Look here for further information.


And again, thank you! I just did the update and everything appears to be normal now. I appreciate your link to the bug information.

1 Like