Slow boot / Black screen after kernel selections F31

Hi everyone,

I have been trying fix my boot problem after kernel upgrade.
Basically, after kernel upgrade I re-generad grub conf. When I try reboot or turn on laptop sometimes black screen shows up or kernel boot list shows up. Also there is significant dracut-initqueue.service delay.

Startup finished in 4.848s (firmware) + 1.662s (loader) + 1.687s (kernel) + 20.970s (initrd) + 23.391s (userspace) = 52.560s 
20.830s plymouth-quit-wait.service                                             >
20.100s dracut-initqueue.service                                               >
12.395s systemd-cryptsetup@luks\x2d3a756f06\x2dd98f\x2d4adf\x2dbca2\x2d554f50f1>
 6.184s fwupd.service                                                          >
 5.030s bolt.service                                                           >
  856ms lvm2-monitor.service                                                   >
  702ms systemd-logind.service                                                 >
  481ms dnf-makecache.service                                                  >
  477ms initrd-switch-root.service                                             >
  466ms vboxdrv.service                                                        >
  367ms udisks2.service                                                        >
  355ms dkms.service                                                           >
  354ms accounts-daemon.service                                                >
  349ms upower.service                                                         >
  348ms lvm2-pvscan@253:0.service                                              >
  279ms systemd-udevd.service                                                  >
  243ms systemd-journald.service                                               >
  202ms systemd-journal-flush.service                                          >
  164ms ModemManager.service                                                   >
  156ms polkit.service                                                         >
  150ms user@1000.service                                                      >
  138ms avahi-daemon.service                                                   >
  135ms systemd-backlight@leds:dell::kbd_backlight.service @23.384s
└─ @23.384s
  └─systemd-logind.service @2.397s +702ms
    └─ @2.367s
      └─dbus-broker.service @2.424s +31ms
        └─dbus.socket @2.364s
          └─ @2.355s
            └─systemd-update-utmp.service @2.349s +6ms
              └─auditd.service @2.320s +27ms
                └─systemd-tmpfiles-setup.service @2.270s +46ms
                  └─systemd-journal-flush.service @2.066s +202ms
                    └─var.mount @1.967s +13ms
                      └─systemd-fsck@dev-mapper-fedora\x2dvar.service @1.950s +>
                        └─dev-mapper-fedora\x2dvar.device @1.949s

Thanks for any suggestions or help.

No run operating system. Maybe totally unrelated. But – temporarily – your can try to disable secure boot.

There were suggestions: Try powerOFF/powerON instead of reboots and suspend-resume (i didn’t get what exactly “turn on” means here). (“Some Wi-Fi cards need proper shutdown in some cases” or such.)

PS: what is your GRUB config (link)? (Two swap files trouble, mostly).

dmesg --level=emerg,alert,crit,err,warn

journalctl -e -b -0

systemctl list-units --failed
1 Like

Sorry, I meant poweroff. Secure boot disabled.

systemctl list-units --failed

0 loaded units listed.
grub file:

GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora-swap rd.luks.uuid=luks- (luks id) rhgb quiet nomodeset=0"

25.153008] usb usb1-port10: disabled by hub (EMI?), re-enabling...

 25.917540] iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS

[   26.128420] iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS
[   27.201107] Bluetooth: hci0: command 0xfc09 tx timeout
[   35.521367] Bluetooth: hci0: Failed to send firmware data (-110)
[   87.316383] hdaudio hdaudioC0D2: Unable to bind the codec

[  255.855830] iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS

[  407.039035] iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS

There are red.

Edit: How can I check correct luks addressed?

Is the only option that differ from my /etc/default/grub.
Try (preferably temporarily, if possible):

  1. Remove it.
  2. Change it to nomodeset (without =0).

Do your using proprietary graphics drivers? Try open-source drivers. Or reverse.
I’m steel have no idea about luks. Probably it is correct… i hope.

AskUbuntu: “What does nomodeset do?”
Asked ~7 years ago.

remove it.

Still same.
I was tryin this solution.

Did your tried to change it to nomodeset?

I tried both. Still same. After re-configure grub file
reboot > stuck black & dells logo > force to shut down laptop > turn on again > boot options > select latest kernel > sometimes can access desktop and sometimes same black screen.

By the way I already did clean install. Problems appears after kernel upgrade. I was using with pre-installed with kernel-5.3.7-301. There was no problem at that time.


@xtym, please, if your willing:

Boot process either produces the black screen, or very slowly boots into OS

CPU is Intel.
Graphics is:

lspci -k | grep -iA3 vga

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (Whiskey Lake) (rev 02)
DeviceName: Onboard - Video
Subsystem: Dell Device 08b8
Kernel modules: i915

How it’s looks like:

1 Like

Hi @vits95 i am lately too much busy …He should try post the output of journalctl where the boots did failed like you indicated before, there should be something in the journalctl

He can try run the kernel 5.4 if this fail he should select the one that did work and look back look journalctl -b2 -b3 -b5 so on or another options would use the options --since= and --until= (what can be useful in this case too)

Edit 1: and if nothing is grab try boot without the parameters rhgb quiet so that one can see where it is failing and he can take a picture too. just in case.


Please post or attach the output from

sudo grub2-editenv list
systemd-analyze plot > sdanalyzeplot.svg

Also, what’s the configuration? Encrypted root, home, swap on LVM? Or other?

Update: OK feel free to skip the above, I just re-read the whole thread :stuck_out_tongue:

I suspect what you’re experiencing is this loop:

  1. Boots the new kernel
  2. Boot fails, grub-boot-success.service does not mark boot successful.
  3. Force reboot, GRUB sees previous boot wasn’t successful so it shows GRUB menu
  4. You pick the older kernel
  5. System boots OK, you login, grub-boot-success.service marks boot successful
  6. Later you boot/reboot again, GRUB sees previous boot was successful so it doesn’t show the GRUB menu at all, but boots the default kernel, which is the most recently installed kernel that seems to be giving you a hard time. - return to 2.)

You might be getting hit by an i915 bug in 5.4 that’s been giving users and devs fits for a while. But so far I’ve only seen reports of it affecting Kaby Lake and Sky Lake, where you have Whiskey Lake. So I’m not certain if you’re hitting this same bug or a different one. The easiest thing to do is stick with the 5.3.7 kernel that’s working.

The way to make it the default kernel with a hidden GRUB menu:

sudo ls -l /boot/loader/entries

This lists the GRUB bootloader entry snippets. Find the one for the kernel that works and copy the filename. Paste it at the end of the following command, deleting the filename extension., e.g.

sudo grub2-set-default ce3f1eade82d42bd891a8c15714b13cf-5.3.18-300.fc31.x86_64

That’s it. That’ll fix the problem until the next kernel update is installed. When a new kernel is installed, it’s made the default. So you’ll just have to be ready to go through this again if the bug isn’t fixed in the new kernel.


Take attention to fact, that by default only 3 most recent Kernel versions will be kept by dnf (remedy in [Howto] inside of quote below).

File a bug, please. Keep as reference the (alphabetical) chrismurphy, and xtym's comments, and a link “file a bug” inside of quote.

I try to set default working kernel (5.3.7-301 for me). but did not work. after reboot straight up boots latest kernel (5.4.13) without issue. But my problem was when I shut down laptop and leave like that for a couple hours then I have a problem with boots.

Update: seems like kernel-5.4.15-200 solves my problem. I can boot my laptop without this issue (just one time happened black screen)

from these experience:

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg (updates grub file)
sudo grub2-set-default (sets default kernel for boot)

also I reinstalled “grub2-efi shim” maybe this help too.

Thank you everyone.
If you have suggestions for post- kernel updates. I like to hear those configurations.

Turns out nothing wrong fedora or my installations. Dell bios has microcode issue. After disabling with dis_ucode_ldr I can boot without issue. I can confirm this also works with my latitude 5400.

Just in the case someone has similar problem.

1 Like

Hi @wa4q,
I’m having the exact same problem that you described above:

    > stuck black & dells logo
    > force to shut down laptop
    > turn on again
    > boot options
    > select latest kernel
    > sometimes can access desktop and sometimes same black screen.

As you said, this only happens sometimes and for now I’m forced to perform a hard reboot via the power button.
I tried adding dis_ucode_ldr to my grub parameters by pressing e when the system boots, and this is what it looks like:

GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora_localhost--live-swap rhgb quiet  rd.driver.blacklist=nouveau dis_ucode_ldr"

The kernel version I’m using is 5.5.8-200.fc31.x86_64 and the laptop is a Dell XPS 15 9560 with Fedora 31.
I recently upgraded the OS version, and I’ve never had any problems with Fedora 30.

Am I doing something wrong?
Thanks a lot

Hi @costamagnamatt Did you recently upgraded the bios? If it’s not that’s maybe not the case for you.

Grub file seems right. Did you tried update grub file with terminal

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

1 Like

I don’t remember any recent BIOS upgrade. I haven’t actually modified my grub file yet, I only tried editing the boot options by pressing “e” during the startup. Tomorrow I’ll try editing the grub file and I’ll post the result.

Thanks a lot in advance!

Hi all,

sorry for the late reply, I wanted to test if the given solution is really working so I took some more days to post my result.
I confirm that the solution given by @wa4q is working for Dell XPS 15 9560 as well.
You actually have to update the grub file, not just the one time boot options at system startup.

Thanks a lot!

1 Like

Here’s an update.

After a few days from my last post the problem is back.
I don’t know what made it showing up again, my grub file is the same as the one i posted before and my current firmware version is 5.5.11-200.fc31.x86_64.

I’ll post below the partial output of dmidecode:

BIOS Information
        Vendor: Dell Inc.
        Version: 1.18.0
        Release Date: 11/17/2019
        Address: 0xF0000
        Runtime Size: 64 kB
        ROM Size: 16 MB
                PCI is supported
                PNP is supported
                BIOS is upgradeable
                BIOS shadowing is allowed
                Boot from CD is supported
                Selectable boot is supported
                EDD is supported
                Japanese floppy for NEC 9800 1.2 MB is supported (int 13h)
                5.25"/1.2 MB floppy services are supported (int 13h)
                3.5"/720 kB floppy services are supported (int 13h)
                3.5"/2.88 MB floppy services are supported (int 13h)
                Print screen service is supported (int 5h)
                8042 keyboard services are supported (int 9h)
                Serial services are supported (int 14h)
                Printer services are supported (int 17h)
                ACPI is supported
                USB legacy is supported
                Smart battery is supported
                BIOS boot specification is supported
                Function key-initiated network boot is supported
                Targeted content distribution is supported
                UEFI is supported
        BIOS Revision: 1.18

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.