sixg0000d/v2ray

Epel for CentOS 6 i386 (0)*, x86_64 (0)* Epel for CentOS 6 (0 downloads) Epel for CentOS 7 aarch64 (0)*, x86_64 (0)* Epel for CentOS 7 (0 downloads) Epel for CentOS 8 aarch64 (0)*, x86_64 (0)* Epel for CentOS 8 (0 downloads) Fedora 31 aarch64 (0)*, armhfp (0)*, i386 (0)*, s390x (0)*, x86_64 (0)* Fedora 31 (0 downloads) Fedora 32 aarch64 (0)*, armhfp (0)*, i386 (0)*, s390x (0)*, x86_64 (0)* Fedora 32 (0 downloads) Fedora 33 aarch64 (0)*, armhfp (0)*, i386 (0)*, s390x (0)*, x86_64 (0)* Fedora 33 (0 downloads) Fedora rawhide aarch64 (0)*, armhfp (0)*, i386 (0)*, s390x (0)*, x86_64 (0)* Fedora rawhide (0 downloads)

This is a companion discussion topic for the original entry at https://copr.fedorainfracloud.org/coprs/sixg0000d/v2ray/

version 4.27 can be installed sucessfully but newer version gives an ‘error unpacking the rpm package’ output during the installation.

Error shows with package v2ray only. Others can be installed properly

Can you provide a more detailed log?

Because this v2ray package in this project is started from 4.28.2, so there is no v2ray-4.27.0 in this COPR project.
I think you may have enable the COPR with the same name (and same url) before (check if your package is named v2ray-core so that is), I have remove and re-create COPR sixg0000d/v2ray earlier, I’m sorry for no warning about this.
If you are in the above situation, I recommend you:

  1. Backup all of your v2ray configuration files, and then delete the directory /etc/v2ray.
  2. Remove the old v2ray package with dnf remove /usr/bin/v2ray (and remove other packages from old COPR which you installed, I recommend).
  3. Remove the old COPR with dnf copr remove sixg0000d/v2ray.
  4. Now, you can re-enable the copr with dnf copr enable sixg0000d/v2ray, and then you can install packages from this COPR, have fun.

Thanks for replying.
Well,I’ve tried your recommedation but it still goes with this error.
There’s no further infomation by default.
It there any other option I can use?

I’ve reinstalled v2ray 4.27 in your qv2ray-test copr.
But the qv2ray gui returns a segmentation fault when running.
distro fedora33

I tried to install v2ray on KVM Fedora 33, but I cannot reproduce this error.
Could you try to install in verbose mode and monitor what happens?

sudo dnf clean all
sudo dnf install v2ray -v --refresh

And you can download the v2ray rpm:

dnf download v2ray

Then query the rpm packaged files

$ rpm -ql v2ray-4.30.0-1.fc33.x86_64.rpm
# They should be:
/etc/v2ray
/etc/v2ray/config.json
/usr/bin/v2ctl
/usr/bin/v2ray
/usr/lib/.build-id
/usr/lib/.build-id/04
/usr/lib/.build-id/04/d2953c66869c256ee01edade60966a7900e546
/usr/lib/.build-id/ee
/usr/lib/.build-id/ee/1cae2c55058f3bcd06bedacc1e59f8a54917a5
/usr/lib/systemd/system/v2ray.service
/usr/lib/systemd/system/v2ray@.service
/usr/share/doc/v2ray
/usr/share/doc/v2ray/README.md
/usr/share/licenses/v2ray
/usr/share/licenses/v2ray/LICENSE
/usr/share/v2ray

If you really can’t install v2ray from my COPR, I regret that, but you can still install v2ray from other repositories and use other packages in my repositories.
The package v2ray-domain-list-community and v2ray-geoip is independ.
And the v2ray-cap (a package for enable v2ray to set IP_TRANSPARENT without root and systemd) is requires any package have install a file into path /usr/bin/v2ray.

sixg0000d/qv2ray-test is just a COPR for test building, and is no longer maintained, I don’t recommend you to use.

If you want to install qv2ray, you can check qv2ray official site.

But the qv2ray gui returns a segmentation fault when running.

Can this help you?

Well, I found that I just can’t install v2ray with version later than 4.27 via any repo.
So I’m gonna try other form of packages.
Thanks

But the qv2ray gui returns a segmentation fault when running.

I occured this error today as well, and I figure out the reason and solved on my new build:
TLO + QT + GLib = segmentation fault anyway.
Now, I disabled TLO on my specfile, feel free to use my new copr build.