Since the latest update to Fedora 37 I keep getting slowdowns/crashes

Hi all,

As the title says, since the update to Fedora 37 I keep getting short slowdowns/stutters once every while (once per 2 hours maybe) and very rarely a total crash. When that happens the screen turns green and the last playing sound repeats several times the last second or so and then stops. All I can do then is reset the computer. These slowdowns or crashes appear at seemingly random moments: reading a webpage, playing factorio, watching a video on youtube. It does not seem related to anything the user does and I cannot reproduce it as I don’t know what causes it.

ASrock Deskmini X300 with BIOS 1.70
AMD Ryzen 5 4650G
RAM: HyperX Impact 16GB DDR4 3200 MHz 16GB DDR4 3200MHz
Samsung 970 EVO 1TB M.2 SSD

I’ve tried searching for this issue but can’t find any similar problems. Also, I’m not that adept at linux that I know how to evaluate system logs etc.

If anyone can help me figure out this problem I’d be very grateful.

Just to be clear — this was not happening with F37 previously, but after a recent batch of updates, it is? (As opposed to: updating to F37 from F36 or earlier.)

If that’s right, can you try booting to the previous kernel to see what happens?

Even if you are not an expert, try running the “Logs” application. Check under “Hardware” — does anything look dramatic there?

I’m not exactly sure when this started happening, but it was shortly after updating from F36 to F37.

The logs application shows a lot of text, I’m not sure what’s important here and what isn’t. It does say several things that seem alarming:

The latest total crash happened somewhere around 17 or 18 hours which prompted me to now write this topic.

Just throwing it out there - sounds like possibly an extreme manifestation of the AMD fTPM-related stuttering issue?

Follow this advice at your own risk, but…it looks like the manufacturer of that system has released a BIOS version that includes the version of AMD’s “AGESA” libraries with a supposed fix:

If it seems to fit the pattern of “AMD stuttering”, it may be worth a shot.

Most of the log messages in that screenshot look benign, but let’s get the full logs and see.

Enter the following commands in your Terminal app. The $ represents your prompt (don’t copy/type it, but everything after it).

  1. Get the list of recent boots.

    $ journalctl --list-boots -r | head

    The left column is the index; 0 is the current boot, -1 is the previous boot, etc. On the right are the times for the first and last messages of each boot.

    Find the last boot where you crashed. If you crashed at 17:00 yesterday, the last message should be at or just before 17:00.

  2. Upload the logs to the Fedora pastebin.

    Let’s say the boot you want is the 2nd last one (-2). You can upload it like this:

    $ journalctl -b-2 | fpaste

    You will be given a URL. Please copy and paste it here.

Hmm, that’s really convenient. This is the log from the boot where I crashed.

I just had a slowdown (not a crash) at 1:48 AM. This is the log:

There’s a lot of this around that time:

  • mrt 11 01:48:47 avitus steam.desktop[18043]: Steam: An X Error occurred
  • mrt 11 01:48:47 avitus steam.desktop[18043]: X Error of failed request: BadWindow (invalid Window parameter)
  • mrt 11 01:48:47 avitus steam.desktop[18043]: Major opcode of failed request: 20 (X_GetProperty)
  • mrt 11 01:48:47 avitus steam.desktop[18043]: Resource id in failed request: 0x0
  • mrt 11 01:48:47 avitus steam.desktop[18043]: Serial number of failed request: 9
  • mrt 11 01:48:47 avitus steam.desktop[18043]: xerror_handler: X failed, continuing

It seems Steam and the X window system have an error together. I’m running standard Fedora so I believe the window manager is wayland. What does this mean?

Sorry, not much insight on the specific issue, but FWIW I play games through Steam as well and have a bunch of those errors in my logs as well, but I don’t have the same issue you’re experiencing, so they seem unlikely to be related.

And you probably are running under Wayland (you can use inxi -Fzxx - which may need to be installed through dnf - and post that here to show other system information for folks who to possibly use in helping, and to help double-check stuff like that), but to my understanding Steam runs games under XWayland to accommodate Wine still needing X?

You are using Wayland. Steam runs through Xwayland, because Steam client
itself (with embedded Chromium), Steam overlay still only work on X.

Can’t see what the cause of the slowdowns/crashes is from these logs.

You are using the integrated GPU of your Ryzen 5 4650G, yes?

Some things I would try (one by one, not all at once):

  • Use X11 session. There should be an option on the GNOME login screen.
  • Check thermals, make sure the CPU isn’t overheating. You can use
    htop (requires lm_sensors). There might also be GNOME extensions
    that are easier to use (I don’t use GNOME so you’ll have to look it up).
  • Test the RAM
    Running `memtest86+` on an EFI system - #14 by hobbes1069
  • Update the BIOS as John mentioned

One thing I have noted with steam is that for certain games the version of proton applied to that game does sometimes matter. I had to set it to a much older version of proton to run the civilization series of games. The version of proton can cause complete failure or simply frustrating performance. Steam can also have multiple versions of proton installed at the same time.