Simplescreenrecorder tray icon not showing the correct status on Fedora 32


HI Team,

I am using simplescreenrecorder package provided from rpm fusion repository for screen recording.

Currently i have it installed on Fedora 32 workstation. But whenever i try to start/stop or pause the recording it is not showing the correct status in the tray icon. I have attached the screen on the same
Package - simplescreenrecorder-0.4.2-3.fc32.x86_64

But this same functionality is working fine in Fedora 31 workstation. I am able to see the screen recording status correctly in the tray icon. Attached the same screen.

As simplescreenrecorder is dependent on the Qt package i tried to downgrade the below packages and by installing the versions available in Fedora 31 but that didn’t helped in resolving that issue.

Qt packages installed on Fedora 32 -

Qt packages that i tried to downgrade on Fedora 32 -

I am trying to figure out what might be affecting this tray icon which is not showing correct status in Fedora 32. Let me know if there is any other package dependency that i had to look into.

Kindly suggest.

1 Like

Hi Team, After further looking it seems in Fedora 31 the below default icons where available in the theme’s specfic folder that is active on my dekstop

[root@fed31 icons]# find . -name simplescreenrecorder-* | grep -v hicolor

But when i check the same on Fedora 32 in the default theme icons folder there was only one default png file which was loading for every operation (eg recording, pausing etc)

[root@fed32 apps]# pwd
[root@fed32 apps]# find . -name simplescreenrecorder*

I tried to copy the .png images from simplescreenrecorder packaged rpm into the theme specific folder and was able to get the correct tray icon status for every action on the application.

But one thing i don’t understand how these default icon files are getting into the theme specific folder which are different from the ones that the application packages (ie. under /usr/share/icons/hicolor//apps/).

1 Like