Silverblue won't snap

since flatpaks disappointed me i decided to go with snaps.

on silverblue 33 i always got an error installing snapd but on silverblue 34 i was able to install snapd but that was it.

i tried installing various snaps but i kept getting : error unable to contact store

did anyone have any luck with snaps on silverblue?

or are snaps not compatible with silverblue?

1 Like

Last time I checked, snapd need write access to a read-only file location under the Silverblue filesystem, so it is hard to make snapd work under Silverblue.

1 Like

This is why Snaps don’t work with Silverblue … https://github.com/coreos/rpm-ostree/issues/1711

3 Likes

Please elaborate. I have always found snaps significantly more problematic, and am curious to know what about flatpaks is the issue exactly. There are plenty of user and contributors in the SB community trying to make flatpaks better.

4 Likes

Most of the issues brought up in that thread are not technically Flatpak limitations, nor are they handled any better by Snap (eg mentioned apps missing a Flatpak don’t offer a Snap either).

celluloid flatpak gave subtitle errors with various mkv & mp4 files. either no subtitles or subtitles out of sync.

I do not personally experience this, therefore I cannot comment on it.

clamav has no flatpak. clamtk flatpak will only scan files saved by the user & not the home folder or any other system folder.

I haven’t ever had a need for any antivirus on Linux, with that being said if you’re only interested in scanning files you could have just added root fs access to said Flatpak and let it access any directory there is.
It’s just a flatpak override away, but you could also use Flatseal to manage permissions via a gui interface.

epiphany flatpak freezes often & for various youtube videos there is no sound.

I don’t use Epiphany. Are you using the Flathub or Fedora Flatpak for it?

ffmpeg & ffmpegthumbnailer have no flatpaks.

You don’t need a separate Flatpak for ffmpeg, it’s an extension of the freedesktop Platform runtime.

Simply use it as flatpak run --command=ffmpeg org.freedesktop.Platform, it’s probably already pulled in as a dependency by other major apps.
There’s currently no Flatpak for ffmpegthumbnailer. You should stick with toolbox unfortunately.

mediawriter, why go the way flathub way for just one app.

Cause Flathub is de facto accepted as the Flatpak repository and mostly every single other one is a huge meme, except for ones maintained by upstream projects like Gnome’s and KDE’s.

Fedora only has its own repo cause software shipped with it currently has to be built by Fedora itself, plus there’s currently no direct way to exclude proprietary software (which Fedora can’t provide), though there’s been talk about filters and whitelists being put in place so as for it to be included in the future.

If the problematic apps mentioned above are being pulled in from Fedora’s remote you should give the Flathub builds a try. I’m fairly sure you won’t come across the same issues.

samba has no flatpak.

True enough.

thunderbird flatpak & transmission flatpak both have no audio alerts.

I never personally pay attention to audio alerts. Do libnotify notifiacations for them work as expected?

edit: typos

3 Likes

I’m afraid this is too low level in the platform to ever be available as a Flatpak but this could be added to Silverblue (is support not already there?)

That sounds fixable. Have you opened an issue upstream in Flathub?

You can use multiple Flatpak remotes without any issue, even if it is just for one application. That’s completely supported in the Flatpak model.

2 Likes

Your first comment is very interesting. So as a general rule, you would first use flathub and if not possible then try is with Ostsee for low level things. Nothing else, I assume.

1 Like

I’m not sure about why you’re quoting me on this as I’m only quoting OP’s post from the linked thread.

I’m well aware of that, but using the Fedora remote in addition to Flathub is pretty much pointless from an end user’s perspective, unless there’s a niche app you can find there that’s somehow not available on Flathub at the moment.

Fedora Flatpaks depend on Fedora Platform, therefore you’re going to have to install at least one additional version of said runtime.
As far as I remember, it lacks extensions support and offers no themes too, even though tbh, overriding ~/.themes is by far more sane a choice than hunting down Flatpak themes despite supposedly being prone to incompatibilities and whatnot.

It’s worth noting that certain Flathub Flatpaks are also official, most importantly Firefox, in which case you get more codecs on Flathub anyway due to licensing.

Personally, I’ve yet to encounter a case where Fedora remote could yield better results than Flathub.

Sorry, I quoted what was in the reply. I understood it’s not your reply but a quote of someone else’s. Sorry for the confusion.

Fedora Flatpaks are there because they are the only ones that can be installed by default for licensing, etc. reasons (see the latest discussion on the topic in Flathub and the bundled software policy - #3 by toMeloos). Moreover, having them and the runtime installed does not really increase disk usage much as most content is de-duplicated already thanks to ostree.

What I usually do:

  • Look for the app on Flathub
  • Look for the app in GNOME Nightly / KDE Nightly Flatpak repos
  • Look for the app in Fedora Flatpak repo
  • Consider packaging the app for Flathub (it’s really easy, reach out, we can help)
  • Consider running from a toolbox
  • Consider installing from a pre-build binary / tar.gz if it’s just for a one shot usage
  • Overlaying with rpm-ostree if none of the above applies or works well. We have now added a live-update mode to rpm-ostree so you can even apply your changes live on your system without needing to reboot if you think this is safe (it mostly is if you’re just installing new apps)
3 Likes

That sounds very reasonable. Thanks for that.

I know why the repo exists. That does not make it any more desirable for an end user though.
I don’t believe different runtimes share files with ostree. Are you sure that’s the case?

If you’re using Flatpak you’re almost always going to rely on Flathub for at least a couple of apps, therefore you’ll be using the freedesktop platform or its kde/gnome derivatives.
Contrary to that, I can’t think of any single major app that’s solely available on Fedora’s repo, therefore one wouldn’t even need its runtime to be installed in the first place, whereas chances are they’d need org.freedesktop.Platform.

This is all over a couple of gigs granted.
I’d definitely use Fedora Platform over Snap :wink:

1 Like

Do you mean in Nautilus? You can set preferences on what file types/location to view thumbnails from, as in this screenshot

There’s absolutely no reason not to combine these though.
I’d rather only use Flatpak, but if a piece of software isn’t readily available or just won’t work with Flatpak due to fundamental issues with the way it interacts with the base system then I’ll just install it in a toolbox or, failing that, simply layer it.

You’re not really obliged to use or like Flatpak, but if you insist on layering everything then there’s pretty much almost no benefit in using Silverblue in the first place, except for update-proof rollbacks maybe, but then again you’d be sacrificing convenience and working around certain software that flatout won’t work with ostree, so you’d probably still be better off with Workstation anyway.

Silverblue is still WIP. It wasn’t until a couple releases back or so that a few system apps finally got removed from the base system image and replaced by Flatpak versions.
Firefox is definitely going to follow suit at some point, but it’s only going to happen when deemed stable enough to do so.

Until such time comes, you can simply remove Firefox from the base deployment yourself and replace it with the official Mozilla build from Flathub. It’s like 2 commands away if you already have Flathub available as a remote:
rpm-ostree override remove firefox
flatpak install flathub org.mozilla.firefox

That’s all, Firefox is now gone from your deployments.
Updating with rpm-ostree won’t bring it back either, unless you reset your override.
You may now enjoy Flathub/Fedora Firefox or any other browser you wish to install through Flatpak, Toolbox or even layer with rpm-ostree.

OpenShift and OKD uses it to update the cluster. For complex scenarios, it’s very useful. For setting up different development-environments, you may want to install the toolbox on a standard installation. If that make sense.

I have never had a good experience with Epiphany, always slow and doesn’t render many sites properly. I thought it was why it is the one GNOME core app omission from Fedora.

Seems like OP wants a polished and completely finished OS but Silverblue is not that quite yet. It certainly is not some “meal made from leftovers” either, that is an insult to the folks at Red Hat, GNOME, and the community who have worked hard on bringing everything together around rpm-ostree, podman, and Flatpaks.

Sure you can point to some papercuts, but on the whole I use all Flatpaks – I installed the Flathub FF and removed the layerd one – and I’ve had a great experience with Silverblue.

1 Like