Silverblue: Russian Keymap not shown in Settings

Good day,

Right now using Fedora Silverblue 32 (up to date). I have the computer set with 3 input sources, English (intl., with AltGr dead keys), Russian (phonetic m17n) and Chinese (intelligent pinyin) in Region and Language Settings, being default language English (United States) and default format English (Ireland).

In “Region & Language” settings, I have no way to view the Russian Layout when clicking on the “View layout” button. I can only see the English Layout, even the chinese layout does not show up when clicking on the “view layout” button.

It did work before, at least on Silverblue 31. I haven’t noticed this since I updated to Silverblue 32 because actually I didn’t need to view the Russian layout before. I just can’t remember now where some keys are in the Russian layout so I went check it and it’s not possible to view it.

Would appreciate any hint on how to solve this issue.

Thanks in advance.