Silverblue and epiphany

My understanding is the following:

epiphany-runtime is part of the base install as it is need for gnome-software webapps

When you issue rpm-ostree install epiphany you install this package which provides a /usr/share/applications/org.gnome.Epiphany.desktop file and a few other bits (Gnome integration, help, etc).

In fact, If you were to overlay epiphany-runtime you would get the the following error:

$ rpm-ostree install epiphany-runtime
error: "epiphany-runtime" is already provided by: epiphany-runtime-1:3.32.3-1.fc30.x86_64. Use --allow-inactive to explicitly require it.