Silverblue: Anacona leads to unusable System

I just found a curious bug(?) in the Anaconda installer. i have a device with a small screen (can’t change this) so the graphic installer can’t be used, so i decide to use the inst.text kernel parameter to enable VNC during installation. This works great, but on the installed System, GDM seems to be disabled, as it puts me only to text console - with no User account at all.

So I’m going on with a second try: After installing, don’t reboot, chrooted to /mnt/sysroot and created a user with adduser and add them to the wheel group. That has worked, at least i can login now, GDM is just only one Step away. I just enabled it with

sudo systemctl enable --now gdm

GDM has been started successfully, but on next reboot, it won’t launched automatically.

So, there are two things missing after text/vnc-installation:

  1. An User to log in
  2. GDM on Startup

at least, VNC Installation should leave GDM Startup enabled.


found the solution, all you have to do at the End of installation before rebooting is to switch from to To do so, switch to a Terminal, before rebooting the system and type:

chroot /mnt/sysroot
systemctl set-default

Now, back to the installer click reboot (vnc) or press ENTER (text)



There is a new anaconda ready for testing, maybe this would have solved your problem too.
Unfortunately I do not find the link to download it.

But I’m sure I read the announcement.