Silverblue 38 unable to visit university websites when connecting to its WPA2-Enterprise wifi on VPN

I encountered several VPN related bugs when using Silverblue 38 which I didn’t have in MicroOS, another immutable distro.

1. Windscribe VPN not able to connect to any server.
2. I wasn’t able to connect to my university’s websites if I connected to my university wifi. Other websites ran totally fine. This happened to three VPN providers I tested. Already reported the bug here.

It seems VPN experience on Silverblue 38 has been…rocky. I’m wondering if any body else had the same issue here. Would might be the causes of the VPN issues?

I found myself unable to open any of my university’s websites if I connected to my university wifi (WPA2-Enterprise) when using a VPN. No matter which connection method I tried and which server I tried it remained the same. I have tried multiple VPN providers (Mullvad, iVPN, and Windscribe), and the results were the same.

However, I was able to connect to my university’s websites when I connected to my phone hotspot instead of my university wifi. I didn’t have this VPN issue when using other Linux OS before.

Is there any workaround to fix this? Thanks!

1 Like

is it only after fedora38?
1)A naive assumption is that your uni website just blocks any connection with device fingerprint “Fedora/linux” since some admin could be quite (funny or lack of experience).They just assume anyone using linux is a Hacker*.
2)Your vpn is just those common advertised vpn.they even kept your OS environment in your connection.great privacy! while using hotspot probably overwritten the connection.OS as android.In naive sense your hotspot has better privacy.

Not quite sure if 37 has the issue since I just started using Silverblue a few days ago.

I’m pretty sure my uni doesn’t block Linux or Fedora. If I opened the uni website without VPN there was no connection problem.

Perhaps those websites rely on intranet routing and DNS.
You can fix this with PBR and split DNS respectively.

I found that the problem only happened when I used the VPN app, no problem at all when I connected VPN through Wireguard configuration files.

The workaround I used was to enable SOCKS 5 proxy in Firefox with VPN.

Someone just had the same issue on Fedora Workstation, so it might be a upstream issue rather than Silverblue-specific one. Unable to connect to institution's websites when connecting to its WPA2-Enterprise network on Silverblue · Issue #4633 · mullvad/mullvadvpn-app · GitHub

Finally got around to submitting a bug report for this