Several problems after upgrade to f39

(i already posted this on reddit, i hope i can get some help here too)


yesterday i upgraded both of my systems to fedora 39. One of them worked flawlessly after the upgrade, but the other has some serious issues (unfortunately it is also my main machine).

While everything worked as expected on the same evening, the next morning the sound and wifi/bluetooth did not work. I tried fixing the wifi and bluetooth issues myself by installing firmware packages through dnf (such as realtek-firmware), but after rebooting, “Unable to load firmware rtl_nic/rtl8125b-2.fw” still shows up, so i figured i did not fix the problem.

More weirdly, my soundcard only shows up as a pci device when i enter lspci -k in the terminal, but not when i enter aplay -l even after i took the usual debugging steps as seen here (this is my alsa-info file).

Some help would be greatly appreciated, i can also provide more information if necessary.

Welcome to Fedora @gamerik

Just having a quick look to the wiki page you posted shows that the info is from:

This page was last edited on 5 October 2015, at 14:41

In my opinion it could be outdated.

And please focus on one problem at once. I propose that you remove the wifi part from this topic and create an other topic about it. So we can better help you.

A good start point is also Start Here for new users.