Serious ACPI problems on HP Envy

I have been running Fedora 32, 33 and recently upgraded to 34 on HP Envy Model 13 aq1002nw. Fedora boots fine from USB stick, but after installation the OS does not start unless ACPI is explicitly off, but then the battery level is not detected and it is not possible to restart, shut down or suspend the laptop - in any case the screen goes black, but the hardware is up until the power button is pressed down for 10s (it is not the PackageKit daemon issue). I tried a lot of combinations of kernel boot parameters ie. acpi=force with various acpi_osi values, but eventually gave up and settled at “acpi=off apic=off”. What is bothering me the most is that sometimes a combination of kernel params yielded good results, ie. battery meter was shown, or it was possible to shutdown or restart the system normally, but it failed on the next boot and never worked again, so I had to roll back to “acpi=off apic=off”.

I was wondering if anyone else is using this laptop model or came across similar issues and could provide me with some helpful hints. It’s quite a high-end laptop, so it is a real shame that such basic features like power control are failing. Any suggestions or advice are appreciated.

I eventually gave up and installed Ubuntu 20.04. This OS works much better on HP Envy:

  • no need for extra kernel parameters,
  • no issues with restart/suspend,
  • battery level is displayed properly,
  • touch pad works normally.
    All that worked out of the box, there was no need for post-install tweaks.

I am not advertising Ubuntu here, but I just needed a working solution. If anyone succeeded with Fedora installation on HP Envy 13 aq1002nw I will be very interested to know the details.