SELinux preventing GDM from starting in Fedora 31

I already tried to post a different thread before, but I think it didn’t get accepted because of me being labeled as a “new user”, now I should have the requirements to post.

So after having trouble with my upgrade to Fedora 31 because of Gnome not loading, I decided to uninstall and reinstall all NVidia drivers, and it worked. However, after the loading screen, GDM did not load and Fedora asked me to create a new user instead, not recognizing my existing user.
I looked at the journal to see what was wrong and I found a ton of lines similar to this:
SELinux is preventing gdm from read access on the file /var/lib/sss/mc/passwd.

My next step was to disable SELinux for the next boot, and it actually worked!
Nonetheless, I’m pretty sure this is not intended and I’d like to know how I can fix this (besides just adding selinux=0 to the grub entries…)

Thanks in advance for your help :slight_smile:

A post was merged into an existing topic: Gnome won’t start after upgrade to Fedora 31