SELinux issue: Hibernate not working on laptop with eMMC storage

Hi everyone,

I’ve installed Fedora 34 on a load of different laptops. No problems at all. I always create a swap partition, and hibernate always works out of the box. One particular laptop has been giving me problems.

Acer Swift 1 SF114-31
Intel Pentium N3710
64Gb eMMC storage

Hibernate does not work out of the box. The screen briefly goes blank, then I am returned to the lockscreen.

After quite a lot of troubleshooting, and finally posting to Reddit, someone posted that SELinux might be the problem. So as a test, I disabled it. Hibernate worked perfectly, exactly as expected.

I tried to figure out why it worked perfectly on other systems without having to disable SELinux, but not this one. All are x86_64, all have 4Gb minimum RAM. The only thing that I can see is different is that on the other computers I’ve used F34 on, the storage is available as /dev/sdx. On this laptop, it’s /dev/mmcblk0.

Someone on Reddit suggested that this may actually be a bug and I should report it on Bugtracker. But I thought I’d post here first and see if anyone else has come across it. I am aware that I can create an rule in SELinux but I feel like this should work out of the box, as it does with other systems.

Laptop works perfect otherwise!

Any thoughts/help appreciated.


Now on Bugzilla:

Hello @deepestbluefedora ,
I don’t know if you have solved this for yourself but I noted something today with my system.
I am heading out to a customer site this morning and decided to put my desktop into hibernate. Systemd spat out an error complaining that swap space was insufficient to perform hibernate operation. I checked my swap status with swapon --show and saw

/dev/zram0 partition   8G   0B  100

This is something I have not done even on my laptop with Fedora Silverblue on it since when not in use I generally turn things off, energy efficiency and all. I wonder if it is related to your issue.