Selinux help me deal with it

Hey Guys!

For years in my Desktop, I allays avoid deal with it, and disable it.

Yesterday, i update f34 to f35, so selinux keep blocking and reporting sometimes after login.

In reading about selinux, to try understand it better e live with it enabled.

Since i updated yesterday i need rebuild the context files? I keep getting reports like this:

SELinux is preventing systemd-user-ru from unlink access on the sock_file bus.
Jan 18 16:16:14 setroubleshoot[1781]: SELinux is preventing systemd-user-ru from unlink access on the sock_file bus.#012#012*****  Plugin catchall (100. confidence) suggests   **************************#012#012If you believe that systemd-user-ru should be allowed unlink access on the bus sock_file by default.#012Then you should report this as a bug.#012You can generate a local policy module to allow this access.#012Do#012allow this access for now by executing:#012# ausearch -c 'systemd-user-ru' --raw | audit2allow -M my-systemduserru#012# semodule -X 300 -i my-systemduserru.pp#012

Thanks for the advance.

Read up on selinux management.

You upgraded from 34 to 35 and had selinux disabled previously. That means it is likely that a lot of the file system files may not have the proper context to allow selinux management.

The first step, with selinux enabled, would be to do a full relabel of the file system. That is easiest done with a simple sudo touch /.autorelabel. The next time you reboot selinux will do a full relabel of the full file system and may eliminate those errors.

If the errors continue after the relabel is complete that is something more to address and detailed info would be needed.

Note that each of those messages gives you a solution guide.

1 Like

the answer given here does nothing to solve the problem but thanks for the response. this just happened to me yesterday when selinux had a policy update. so far it has not caused any problems I can see so I will leave it alone for now. i can allow it later ounce I figure out what it’s trying to do. If selinux is stopping a normal function. I would suspect more people will have the same warning at boot as they update. This was a fresh install of f35. this happens from time to time on fedora with selinux. fedora is stable but it is used for development and testing so bugs pop up. I have a couple i,m working to correct right now. thats the fun for me anyway

1 Like

Hi. I get that setroubleshoot alert too (on Fedora 34) for a few days now. There is a bug filed for it:

Bug 2039388 - SELinux is preventing systemd-user-ru from unlink access on the sock_file bus

1 Like

Your situation is not the same as the OP so your comment is meaningless. You have a new install, he did an update where previously he had selinux disabled.

Hey guys, i read a lot. (and will continue my readings)

And rebuild all context files.
I uninstalled all selinux-policy* and all context in “/etc/selinux/targeted” and “/etc/selinux/config”
Install selinux-policy* and touch /.autorelabel and reboot

To recreate.
Same issue.

Looks like Robin issue, but without host field.

My laptop has the same issue too. Updated yesterday to f35, and it always had selinux enabled. (But i forget to check before update.)

This laptop has almost nothing installed, all is from fc repo. Used just for browsing.

This issue looks like a flaw.

Many Thanks!

Edit: I created the rule to add acesss

 ausearch -c 'systemd-user-ru' --raw | audit2allow -M my-systemduserru
 semodule  -i my-systemduserru.pp

How i remove it now? selinux updated today. And i want test more.

Many Thanks!!

Edit again:
List my created modules
semodule -l | grep my
semodule -r modulename

1 Like

For these reasons I removed/disabled selinux (in the past), always I try to use it again here come these flaws. :thinking:

But this time i will persist. :sweat_smile:


Hey Guys!

After the last 2 updates. Fixed! The flaw gone.

Many Thanks for support.


Glad it is resolved. The update seems to have fixed it so please mark the solution post.

1 Like