SDL: Fullscreen not working

I posted about this actually on the SDL discourse, except I thought this would be a better place to ask about this, since this seems to be an issue I’m having with GNOME. I have not had this issue until recently when I opened Xonotic for the first time in a while.

I’ve been having this issue with SDL applications scaling properly, for example Xonotic looks like this:

As you can see, Xonotic is pushed down to my below monitor and the status bar is still showing.
I tried setting the environment variable SDL_VIDEO_MINIMIZE_ON_FOCUS_LOSS=0, but this did not work. For good measures I set this in /bin/sh , bash, and zsh.

Also how do I restore grub2 to complete default? When I boot I get a very verbose init and no nice login :frowning:. Also the lmms package seems to be pretty outdated.