Screensaver does not work on F34

Hi, I recently did fresh installation of fedora 34 and I noticed that even I have set in power management to enter screen save mode (turn off display) to 5 min, it actually never happens and never locks screen on its own. Only way it correctly turns off display is when I manually lock the screen by super+L. But even after that if any event wakes display it won’t go to screen save mode ever again.

I use Gnome on wayland on laptop with external display. I had no such problems on previous fedoras with same setup.

1 Like

Can you please create a new user to see if the issue persists? Perhaps best to create a new user, set the screensaver settings and leave it for the necessary amount of time

Some applications and gnome-shell extensions can “inhibit” the screen saver. This will help us rule them out.

1 Like

Ok, I tried it with new user and it worked just fine. After re-login to my main account I decided to identify which application prevents of screen saving mode. Interestingly enough I found none. Now it suddenly works as it is supposed to. That could mean there was something wrong with my previous session. So I think I should be ok unless it starts happening again.

Thank you for your time and your help.

Ah, great.

Did you update the system recently? Depending on what packages were updated, you should log out and back in (or even reboot) to ensure that the new versions of software are in use.

Yeah I did run sudo dnf update few times since last reboot.

1 Like

That could be it then. Try using the dnf tracer plugin, which points out what processes may need restarting after a transaction:

sudo dnf install python3-dnf-plugin-tracer

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.