Screen Sharing (and window sharing) problem in Fedora 36

So I have a fresh install of Fedora 36 workstation. When I try to share my entire screen or just a single-window. I get a distorted output ( not a black screen ).

I’ve tried:

  • Obs Studio
  • Firefox

Screen sharing works fine in a Xorg session. Here is the output of journalctl while I tried to screen share in firefox

The only lines that look interesting to me are:

fedora firefox[3158]: gdk_wayland_window_configure: assertion 'height > 0' failed
fedora gnome-shell[1681]: ATK Bridge is disabled but a11y has already been enabled.
fedora xdg-desktop-por[2178]: Unhandled parent window type
fedora xdg-desktop-por[2178]: Failed to associate portal window with parent window
fedora wireplumber[1642]: <WpPortalPermissionStorePlugin:0x5570828c71c0> Failed to call Lookup: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for camera

As a reference, before installing Fedora, I tried OpenSUSE tumbeweed and the screen-sharing was perfectly fine there.

I’d be grateful if anyone could help me out with this issue. If any other details / logs are needed please let me know. Thanks.

Are you sure you used Wayland in tumbleweed? As you said Xorg works.
Was it a gnome you tested in open-suse?

Such references to other distribution are always very vague … especially without any details about versions etc.

Indeed it is quite vague, I just wanted to add it as a reference. But yes, I did make sure that it was a wayland session. And it was Gnome on Tumbleweed.
By the way, I have now tried Fedora Kde Spin Live ISO and the issue is there as well.

Yes as mentioned in other topics people do have this problem that it not works with Wayland. But I’m not really sure if it is because screen-sharing is not working or because they use also NVIDIA drivers who are not configured as expected.

Could you please give us more info’s as :
inxi -Fzx in terminal and post the output as </> Preformatted text here.

I found an older article about screen-sharing and Wayland … there it mentions tools how to debug. If you want to give this a try:

I’ll definitely look the article up, when I have some time.

$ inxi -Fzx

  Kernel: 5.18.6-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: GNOME v: 42.2
    Distro: Fedora release 36 (Thirty Six)
  Type: Laptop System: Acer product: Acer One 14 Z422 v: N/A
    serial: <superuser required>
  Mobo: CZL model: Acer One 14 Z422 serial: <superuser required>
    UEFI: American Megatrends v: 1.01 date: 07/13/2018
  ID-1: BAT0 charge: 4.3 Wh (100.0%) condition: 4.3/31.7 Wh (13.6%)
    volts: 16.0 min: 14.4 model: standard status: full
  Info: quad core model: AMD A6-7310 APU with AMD Radeon R4 Graphics bits: 64
    type: MCP arch: Puma rev: 1 cache: L1: 256 KiB L2: 2 MiB
  Speed (MHz): avg: 1030 high: 1065 min/max: 1000/2000 boost: enabled
    cores: 1: 1028 2: 1000 3: 1027 4: 1065 bogomips: 15969
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Mullins [Radeon R4/R5 Graphics]
    vendor: Holco Enterprise Co /Shuttle driver: amdgpu v: kernel
    bus-ID: 00:01.0
  Display: wayland server: X.Org v: with: Xwayland v: 22.1.2
    compositor: gnome-shell driver: X: loaded: radeon
    unloaded: fbdev,modesetting,vesa gpu: amdgpu resolution: 1360x768~60Hz
    renderer: AMD KABINI (LLVM 14.0.0 DRM 3.46 5.18.6-200.fc36.x86_64)
    v: 4.6 Mesa 22.1.2 direct render: Yes
  Device-1: AMD Kabini HDMI/DP Audio vendor: Holco Enterprise Co /Shuttle
    driver: snd_hda_intel v: kernel bus-ID: 00:01.1
  Device-2: AMD FCH Azalia vendor: Holco Enterprise Co /Shuttle
    driver: snd_hda_intel v: kernel bus-ID: 00:14.2
  Sound Server-1: ALSA v: k5.18.6-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: AzureWave
    driver: rtl8723be v: kernel port: e000 bus-ID: 01:00.0
  IF: wlp1s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Holco Enterprise Co /Shuttle driver: r8169 v: kernel port: d000
    bus-ID: 02:00.1
  IF: enp2s0f1 state: down mac: <filter>
  Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 2-1.2:3
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 238.16 GiB used: 20.33 GiB (8.5%)
  ID-1: /dev/sda vendor: Crucial model: CT240BX500SSD1 size: 223.57 GiB
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade
    size: 14.59 GiB
  ID-1: / size: 100.01 GiB used: 7.59 GiB (7.6%) fs: btrfs dev: /dev/sda6
  ID-2: /boot size: 973.4 MiB used: 233.7 MiB (24.0%) fs: ext4
    dev: /dev/sda5
  ID-3: /boot/efi size: 96 MiB used: 41.8 MiB (43.5%) fs: vfat
    dev: /dev/sda1
  ID-4: /home size: 100.01 GiB used: 7.59 GiB (7.6%) fs: btrfs
    dev: /dev/sda6
  ID-1: swap-1 type: zram size: 7.45 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 65.4 C mobo: N/A gpu: amdgpu temp: 68.0 C
  Fan Speeds (RPM): N/A
  Processes: 298 Uptime: 2h 33m Memory: 7.45 GiB used: 3.85 GiB (51.7%)
  Init: systemd runlevel: 5 Compilers: gcc: 12.1.1 Packages: 10
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.16

I got the exact same issue here. Same distorted image. Any ideas?

This may seem obvious, but I have to ask.
Was suse running gnome 42 as is running in fedora 36 or was it some other version?
Was suse running the same version of the kernel and wayland as fedora?

Knowing that the screen sharing works in suse just leads to a lot of questions about what may have been different between fedora 36 and suse tumbleweed that made screen sharing work with wayland on one system but not on the other.

Keep in mind that wayland is a DE that is still under development while xorg is a seasoned veteran and almost all conditions have been considered and the fixes are already in place for X.

Flathub firefox, fedora flatpak firefox or Fedora rpm firefox?

Could this be related to graphics drivers? I noticed that screen sharing works fine on my laptop with same software setup (Fedora 36, Wayland, Gnome 42), but not on my PC. On my PC I have an Nvidia graphics card, but I think it’s not recognized properly, as I can’t use hardware acceleration in programs like Firefox, VLC, Handbrake, etc. Any ideas how to further debug this?

So it seems this is an issue on the PC.
A quick check for the problem with nvidia GPU there would start with checking if the nvidia modules are loaded or if it is using the nouveau drivers.

  1. Did you install the nvidia drivers from rpmfusion?
  2. What is the output of lsmod | grep -iE 'nouveau|nvidia'? (please post that)
  3. If #2 shows nvidia then we can do some further trouble shooting. If it shows nouveau then please install the nvidia drivers since AFAIK nouveau does not support hardware accelleration.
  4. If the nvidia drivers are installed but not shown as loaded in #2 then it is likely an issue with secure boot, but we can drill down there if needed.

I’m using an old AMD hardware and I got the issue as well. I think it’s a driver issue, as I found the problem seems to occur on newer kernel. It works fine on kernel version 5.15 LTS.