Screen flickering/staying fully white after desktop login with new kernels (6.1.6 / 6.1.7)


I recently build a new PC and decided to give Fedora 37 a try. With the installation came kernel 6.0.17 which worked fine. After updating to 6.1.6 when logging into GNOME desktop the screen started flickering rapidly (either looking fine or being fully white) on any desktop interaction, e.g. moving the mouse. When booting 6.0.17 all is fine. After updating to the newest 6.1.7 kernel I hoped for the problems to magically go away, however now the desktop just stays fully white with the exception of the mouse cursor which is visible.

The behavior is the same for both Wayland and x11.

I am using the integrated graphics card of my Ryzen 9 7950X.

Any help or pointers would be appreciated.

I confirm having the same issue. Updating to 6.1.8-200.fc37.x86_64 (available in test updates repository) resolves the issue for me.

i’m having the exact same problem using an Asus motherboard same cpu and only integrated graphics. I was running fedora 37 my iso came with kernel 6.0.7-301.fc37 everything worked fine.
But the three later kernels gave me the problem you described. These are:
6.2.8-200.fc37 and 6.2.9-200.fc37 and 6.2.10-200 same problem.

Did a new clean install this time Fedora 38 i believe it came with 6.2.9-300.fc38 . Same problems as the 6.2.9 for fedora 37. But i managed to open a tty and do an update to 6.2.11-300.fc38 and i’m sorry to report the same problem. i was looking for a way to revert to an older kernel on fedora 38 only thing i found was this post that i tested in vm running on the same hardware but inside windows using vmware pro. i could not find 6.0.7-300 for fc38 but only for fc37 i assume that’s fedora 37 kernel running in fedora 38 doesn’t seem like a good thing start building on. So for now it’s a no go for fedora only windows. Hoping for a kernel release that fixes this.
My first instinct was to report this bug… But i haven’t found a clear howto report this only one hour long vid on youtube talking about submitting a kernel bug. That sounds to complicated to me.

Just updated to kernel 6.2.12-300.fc38. And still having the same problems. That’s on fedora 38 gnome. BTW this problem did not show when booted from usb and going true the install otherwise i would not have installed fedora 38. Looks like i will be dual Booting to fedora 37 hoping i can still get a iso with kernel 6.0.7-301 Looks like that’s still the last working kernel for integrated graphics on Ryzen 9 7950x

I was having this white screen issue as well with my 7950X, because I only had monitor connected to the the iGPU, what I did to work was connect a dummy cable to my monitor from the dGPU, then it worked fine. Not sure if this will gonna help you

i don’t have a dGPU. i’m running 100% on iGPU…
i have looked at the “Sapphire Nitro+ Radeon RX 6700 XT” because i like the review Level1Techs made here but i figure if i don’t need to spend 500 euro as i don’t game that’s a win… i only need the iGPU to ouput 4k @60hz and it does that perfectly that is on windows 11. and fedora 37 running kernel 6.0.7-301
Thanks for your thoughts.

I’m having the exact same problem with Nobara 38 (with Gnome DE), a customized version of Fedora 38. I just built a new system with an AMD 7950X3D on a Gigabyte Auros Elite X670 motherboard. I’m using the built-in iGPU. The monitor is a LG-34WQ, a widescreen 3440x1440.

After logging in and working on the machine, I frequently get a white screen that obscures everything except for the black cursor which I can move around. Sometimes I get the flickering white-and-color screen. It looks like it occurs whether I use 60 or 100hz as the refresh rate in Gnome. It does appear to happen whether I use or Wayland.

Oddly, I also installed Garuda Linux (with Gnome DE), an Arch-derivative, on kernel 6.3.9. It suffers from the same symptoms as Fedora. Now both do run Gnome, so maybe that’s the common element. Or perhaps the iGPU in the Zen4 CPUs are at fault (or their driver in the kernel).

Any ideas what we can do? I was hoping to delay purchasing a dGPU for a while. But if it fixes the problem…

Update: looks like a bug in the kernel. See discussion here. There’s a kernel argument that I’m trying as a temporary fix. See more about that here.