Scanner not found after kernel or other updates updates on 2019. Oct 08th

after some f30 updates last week my scanner is lost. Found it with
lsusb: Bus 001 Device 006: ID 04a9:190f Canon, Inc. CanoScan LiDE 220
Wiith scanimage -L the answer is device `v4l:/dev/video0’ is a Noname HD WebCam: HD WebCam virtual device.
How to switch on again?

I am experiencing a similar issue. However, in my case it is a Pixma MX870 scanner connected via the network. I’ve had this working for years now, but after an update the scanner suddenly stopped being detected by simple-scan. I see in the logs the following messages when I use simple-scan or scanimage:

Oct 26 12:30:39 sleipnir scanimage[3851]: io/hpmud/model.c 537: no on_mx870_series attributes found in /usr/share/hplip/data/models/models.dat
Oct 26 12:30:39 sleipnir scanimage[3851]: io/hpmud/model.c 548: no on_mx870_series attributes found in /usr/share/hplip/data/models/unreleased/unreleased.dat
Oct 26 12:30:39 sleipnir scanimage[3851]: io/hpmud/model.c 537: no hp_on_mx870_series attributes found in /usr/share/hplip/data/models/models.dat
Oct 26 12:30:39 sleipnir scanimage[3851]: io/hpmud/model.c 548: no hp_on_mx870_series attributes found in /usr/share/hplip/data/models/unreleased/unreleased.dat

Do you see anything similar?

Ignore the log output I provided. I managed to check the scanner with another Fedora machine that has not been updated recently. It produces the same log entries, but the scanner works fine. I’m going to keep searching for the cause as I can.

So it looks like the packages of interest might be sane-backends and sane-backends-drivers-scanners. On the machine that works, both of those are 1.0.27. On the machine that doesn’t work they are 1.0.28. I took a quick look at SANE project webiste (, and in 1.0.28, they note “significantly changes canon_dr, fujitsu, genesys, gt68xx, hp5590 and, pixma backends”. That seems suspicious to me.

The next thing for me to try would be to attempt to rollback to 1.0.27 on the machine that doesn’t work to see if the scanner starts working again. I’ll try to do that when I have time.

Well, I dug into this a little more. I don’t know what exactly changed to put me in this state, but in my case it was a network problem. I noticed that if I modified my /etc/sane.d/pixma.conf file to explicitly include an entry for my scanner (e.g. bjnp://mx870), then scanimage -L would find the scanner.

So I investigated my firewall configuration. The network interface I was using was set to the “public” zone, which is pretty restrictive. The computer isn’t on a public network, so I switched it to “FedoraWorkstation”, which opens up a lot of ports (e.g. the ones needed to detect packets from the scanner during discovery). Once I did that “scanimage -L” and simple scan both worked.

So it looks like I’m not much help to you @mio76, as I suspect our problems our different. Hopefully you’ll find a solution.

Today is a good fortune day for Fedora, but I’m not sure it comes from Fedora support self or it is only transfered by other Linux distributions?
First for the history rework. I have an second laptop with an F30 from Aug/Sep 2019. On this laptop my scanner cannon lide 220 was working very well. It was clear that somebody from the developer were again and again on the way to “making something worse while intending to make it better”. Scanners and boot images (with today update of grub I must again link the boot image in the Bios … nothing for normal users of Acer Aspire, worst case with F28, had to wait for F29) with grub seams to be stepchilds for the developers. I forgot it but some fedoras ago it occured in the same way. Today I got the update from sane-backends 1.0.28-1.fc30 → 1.0.28-4.fc30, this made my scanner work again. Solved.
Thanks to cstanhope for support. Hope your scanner works too.