Rygel Media Sharing


Hi good people

Hopefully someone can help here, iv been using rygel on y laptop to share media over my local network, after upgrading to f39 im having some issues, only when trying to play .avi files on a smart tv, its worked under f38, after upgrading to f39 the tv says file type not supported. iv made sure all gstreamer plugins are installed, media plays fine on the laptop, transcoding is still enabled in the users rygel.conf file. im assuming this is because transcoding is not working.

Any ideas are much appreciated!

I don’t use rygel, but do use a media server.

You must ensure all the necessary codecs are available which mostly means you have to install packages such as


All of which come from the rpmfusion-free repo.
That repo can be enabled with instructions here then the packages installed using dnf on the command line.

Some of them require removing or replacing already installed fedora packages so the option --allowerasing may be required for dnf.

Thanks for the reply Jeff!

of that list, mjpegtools and libavcodec-freeworld were not installed, doesnt seem to have solved the issue though. Maybe it will sort it self out with updates at some point. it worked on F38, i used dnf for the upgrade to F39. will post here if i make any progress.

Update, so after running updates on Monday, if i attempt to play something over the network, it crashes the computer. when browsing, thumbnails of videos come up that don’t need transcoding, but the moment i try play something that needs transcoding the laptop crashes. its definitely not an essential for me, but id be happy to provide logs if it would be helpful. iv been using fedora since the single digit versions, but definitely no power user. so if someone could tell me what logs, id be happy to help.