[RTL8822BE] WiFi is unable to find surrounding networks, and keeps on loading

I did a quick search on this forum for RTL8822BE and the chipset (10ec:b822). I found many posts related.
This dates way back to 2021 or earlier.

Not many had encouraging news about the driver.

Since this is a laptop and you seem to hate the inconvenience of the usb dongle it is relatively simple to get a replacement wifi adapter that is supported by linux (intel especially) and replace the default adapter. On most laptops I have worked with the card is immediately accessible when the case is opened and replacement only involves one screw and 2 clip-on antennae wires.

A replacement card seems about $20.

But the thing is it works fine when I first installed fedora on my system, then after an upgrade, it stopped working.

is it a netgear router?

Thanks for this reminder about router/access point hardware.

I have seen cases where power cycling the AP seemed to solve similar problems so that may be worth a try.

Updates to kernels and drivers may also interfere so I try to avoid hardware that seems problematic – such as the particular wifi card in this thread.

Do you still have a bootable USB installer for the version that worked? If so, you can compare the output from lspci -nnk | grep -iA3 -E "network|wifi" as well as journalctl --no-hostname -b -g rtw88.

You previously posted output fromjournalctl --no-hostname -b -g rtw88 with truncated lines (ending in >). Use journalctl --no-hostname -b -g rtw88 | cat to wrap lines.

You previous journalctl output showed:

rtw_8822be 0000:02:00.0: failed to read ASPM, ret=-5

Have you tried disabling ASPM per Power Management Guide: ASPM. Before making the global changes suggested in the guide, check a BIOS setting and for a disable_aspm module option using modinfo rtw_8822be.

If the module option is supported, try:

$ echo "options rtw_pci disable_aspm=Y"  | sudo tee  /etc/modprobe.d/rtw_pci.conf

You will need to force the WiFi card to reset. Try restarting to see if the ASPM message goes away. If not, try:

  • removing the WiFi card
  • unplugging and removing the battery

Unfortunately, I don’t have bootable usb drive with me now. I guess I should buy rj45 to type-c converter to make it permanently connected to router, I don’t have much hope left with me regarding the wifi.

If you can’t implement fixes/workarounds that have “worked” for others with the same hardware you will be better off using more current hardware. Even if you can get older hardware to work, it may not have the same performance as current hardware and you may need new workarounds in the future. Having a way to use ethernet has saved me a lot of trouble in the past while waiting for wifi fixes.

So, you’re also facing the same WiFi issues. Does using Ethernet shows any network lags or something like that?

I’ve been using Unix and then linux for decades. Shortly after internet arrived at my work I was moved to a group that was contracted to process data downloaded from satellites and remote servers. Network was mission-critical, so I have way too much experience with network problems. Until
recently, systems were designed to allow replacing network interfaces. In my experience, network interfaces and memory have too often needed replacement. In one case a system was having problems transferring data to the file server. The vendor’s ethernet diagnostics said the network card was OK, but on visual inspection, there were burned components on the card, and replacing it solved the connection problems. Good quality network cards are not expensive, so replacing an older card with a new model that has good vendor support is often better than trying to work around an issue.

Fedora upgrades have often had transient network issues with older hardware that were fixed with updates. For me, those were easily fixed since I long ago learned to have multiple backup options (wired network, USB wifi dongles).

2 Likes

Even most modern laptops seem to have the wifi network card readily accessible as soon as the case is opened. This seems to make replacement a matter of a few minutes for almost all devices. (unfortunately tablets are a different matter entirely – but then most do not use linux on tablets)

OTOH, interfaces that are built-in on the mobo (mostly ethernet) are not easily replaceable so your solution of having usb dongles available is a great solution when problems develop.