Rpm-ostree install kubeadm gives errors while hardlinking kubelet

Hi folks,

I am looking at the VMware openshift container and found https://mirror.openshift.com/pub/openshift-v4/dependencies/rhcos/latest/rhcos-4.13.10-x86_64-vmware.x86_64.ova

I want to use kubeadm to create clusters. However the above OVA does not contain kubeadm. It has kubelet and kubectl.

I tried to install kubeadm using repo-ostree, but it tries to create a hardlink to kubelet in a readonly FS (since kubelet, kubectl are also getting installed as part of kubeadm).

I am an FCOS newbie and am not sure how to coax repo-ostree in order to get it to install kubeadm. I tried the overlay approach and also tried to change sysroot. None of them worked.

Can someone help me with installing kubeadm.


You’ve linked to an image of RHEL CoreOS which is only available as part of OpenShift (a Red Hat product).

You can get Fedora CoreOS images from https://fedoraproject.org/coreos/download/?stream=stable.

Thanks for the clarification @siosm . Since it was an fcos image I thought this could be the right place to ask such questions.