"rpm-ostree cancel" does not work

My goal was to install dolphin via rpm-ostree because the flatpak version doesn’t have “open with”.

$ rpm-ostree install dolphin --apply-live
error: Updating deployment: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dio_2derror_2dquark.Code26: Transaction in progress: upgrade
 You can cancel the current transaction with `rpm-ostree cancel`
$ rpm-ostree cancel
Cancelling transaction: upgrade
Cancelled.
$ rpm-ostree install dolphin --apply-live
error: Updating deployment: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dio_2derror_2dquark.Code26: Transaction in progress: upgrade
 You can cancel the current transaction with `rpm-ostree cancel
$ rpm-ostree cancel
Cancelling transaction: upgrade
Cancelled. 
$ rpm-ostree install dolphin --apply-live
error: Updating deployment: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dio_2derror_2dquark.Code26: Transaction in progress: upgrade
 You can cancel the current transaction with `rpm-ostree cancel

No idea what’s going on here. It’s probably gone after I reboot but either I can cancel it, or I can’t.

From Proposed Common Issues to Ask Fedora

It looks like there was an update going on when you tried the layering, --apply-live shouldn’t be needed unless it is required for issues with the hardlinks, like post install configuration by dolphin emulator into readonly locations. Perhaps do a rpm-ostree status to make sure it’s idle before trying the install.
[Edit] : Is this for Dolphin Emulator or Dolphin the KDE filemanager, both are in the repos. If you want Dolphin Emulator the command should be rpm-ostre install dolphin-emu instead.

Thx. Good to know that --apply-live is the default behabior nowaways.
I want dolphin file manager. It was hinted by the missing “open with” context menu.

i just wanted to highlight that a cancel command that cancels nothing isn’t working.

Added rpm-ostree and removed flatpak

No --apply-live is not default behavior. Please avoid it when possible as it is likely less stable.

What variant are you on? Layering dolphin will pull in half of KDE Plasma, so you may want to avoid it and use Kinoite.

Also note that Thunar (GTK, XFCE) and pcmanfmqt (Qt, LXQt) are good too.

1 Like

No thats not what I was saying here. I was pointing out that using --apply-live is intended for those times you really need to layer something that does not honour the Linux File System Hierarchy (FSH) and wants to put something in /opt say instead of in /var/opt for instance. In the Atomic versions /var and /etc and /home are writable, but not /. It is also intended as more of a debug tool in that regard, as opposed to a valid solution to getting some desired app to work on the Atomic system.

i just wanted to highlight that a cancel command that cancels nothing isn’t working.

Yeah, it did cancel, but cancelling nothing is maybe not really success.

Thx!

I’m on Fedora Atomic GNOME because of PaperWM because neither karousel nor niri are on par with it.

What’s the problem with having half of KDE Plasma and GNOME?

I’ll have a look into pcmanfmqt. I used thunar a while ago but fell back to dolphin.

1 Like

I don’t understand. The output states a transaction is in progress

That there says the cancelled operation successfully was cancelled

Yes, what does the next lines indicate? To me, it looks like it didn't work.

Well, there is the error you get when trying to install dolphin, the file manager for KDE, on a Gnome DE based install. Which is unrelated to the rpm-ostree cancel command statements. Each of your (shown) cancel commands completed successfully as it indicates in what you posted.
If you want the KDE experience you should try Kinoite, the dolphin file manager will be the default one then. If, however, you are wanting the dolphin-emu package, for emulating gamecube I think it is also available as a flatpak.

it’s not what you are saying. You are a little bit off topic, sorry. Thank you for trying to help.

What’s the output of rpm-ostree status ? If there is something rpm-ostree is doing, it will produce results, if not let’s also try journalctl -xe to see if there are any more pieces of relevant info we can get.

Well, Layering “half of KDE” on an Atomic OS, can potentially cause some issues down the line with updates. Layering is really for software that needs that low level access. I have not personally tried it, but maybe installing dolphin in a toolbox would have been a better solution here.

2 Likes

thx. I’ll remember that command for the next time.

Installing dolphin in distrobox produces other unwanted side effects like the context menu not being aware of any other app outside of distrobox.

1 Like

It’s even more of an issue. Gnome is GTK4 based while KDE is QT5/6 based. They never seem to play well together. If you want the KDE experience in Atomic Fedora use Kinoite, if you want Gnome then use Silverblue.

2 Likes

rpm-ostree didn’t cancel today again. Out put of journalctl -xe

Apr 13 08:21:21 laptop rpm-ostree[17988]: Handling GetPackages for caller :1.134
Apr 13 08:21:21 laptop rpm-ostree[17988]: Enabled rpm-md repositories: copr:copr.fedorainfracloud.org:ublue-os:akmods copr:copr.fedorainfracloud.org:atim:starship updates fedora rpmfusion-free-updates-testing rpmfusion-free-updat>
Apr 13 08:21:28 laptop rpm-ostree[17988]: Importing rpm-md...done
Apr 13 08:21:28 laptop rpm-ostree[17988]: rpm-md repo 'copr:copr.fedorainfracloud.org:ublue-os:akmods' (cached); generated: 2024-03-17T06:02:48Z solvables: 216
Apr 13 08:21:28 laptop rpm-ostree[17988]: rpm-md repo 'copr:copr.fedorainfracloud.org:atim:starship' (cached); generated: 2024-04-05T10:06:29Z solvables: 2
Apr 13 08:21:28 laptop rpm-ostree[17988]: rpm-md repo 'updates' (cached); generated: 2024-04-13T01:08:49Z solvables: 25838
Apr 13 08:21:28 laptop rpm-ostree[17988]: rpm-md repo 'fedora' (cached); generated: 2023-11-01T00:12:39Z solvables: 70825
Apr 13 08:21:28 laptop rpm-ostree[17988]: rpm-md repo 'rpmfusion-free-updates-testing' (cached); generated: 2024-04-09T17:32:50Z solvables: 14
Apr 13 08:21:28 laptop rpm-ostree[17988]: rpm-md repo 'rpmfusion-free-updates' (cached); generated: 2024-04-09T17:32:17Z solvables: 174
Apr 13 08:21:28 laptop rpm-ostree[17988]: rpm-md repo 'rpmfusion-free' (cached); generated: 2023-11-04T16:49:08Z solvables: 445
Apr 13 08:21:28 laptop rpm-ostree[17988]: rpm-md repo 'rpmfusion-nonfree-updates-testing' (cached); generated: 2024-04-09T18:02:39Z solvables: 2
Apr 13 08:21:28 laptop rpm-ostree[17988]: rpm-md repo 'rpmfusion-nonfree-updates' (cached); generated: 2024-04-09T18:02:33Z solvables: 74
Apr 13 08:21:28 laptop rpm-ostree[17988]: rpm-md repo 'rpmfusion-nonfree' (cached); generated: 2023-11-04T17:26:32Z solvables: 208
Apr 13 08:21:28 laptop rpm-ostree[17988]: rpm-md repo 'updates-archive' (cached); generated: 2024-04-13T01:43:29Z solvables: 41700
Apr 13 08:21:28 laptop rpm-ostree[17988]: Handling GetPackages for caller :1.134
Apr 13 08:21:28 laptop rpm-ostree[17988]: Enabled rpm-md repositories: copr:copr.fedorainfracloud.org:ublue-os:akmods copr:copr.fedorainfracloud.org:atim:starship updates fedora rpmfusion-free-updates-testing rpmfusion-free-updat>
Apr 13 08:21:30 laptop kernel: perf: interrupt took too long (4175 > 4080), lowering kernel.perf_event_max_sample_rate to 47000
lines 1152-1201/1201 (END)

I wonder if I really need the testing repositories or if I could just disable them. The log shows that interrupt took too long.

If it is the auto-update right after you boot up Fedora Linux, I think it is triggered by GNOME Software. The command rpm-ostree cancel does not seem to work, because GNOME Software will run the auto-update again if user cancels it manually. I remember having to remove a .desktop file in /etc/xdg/autostart/ to disable the auto-update.

1 Like

that sounds like that’s the problem! Thanks.