Rocm state in f37

FYI I have rocm-hip in review for Fedora 38 if anyone is interested:
https://bugzilla.redhat.com/show_bug.cgi?id=2209759

Feel free to @ me or make bugzilla reports if you see ROCm issues because, I have a hand in most of the Fedora ROCm packages, and it’s good to stay informed in the community discussion.

It’s worth noting that new hardware support is heavily dependant on LLVM, and because ROCm releases with newer unstable LLVM, Fedora’s stable LLVM might at most 6 months on hardware support, although it’s usually not that long. The same is true for mesa support with AMD products.

Fedora 38 recently upgraded to LLVM 16, so it should have brought RDNA3 support, but don’t quote me on that. Generally most if not all products within the last 5 years should work with rocm-opencl, although I can’t really test all HW when I push Fedora updates (community testing on updates-testing/bodhi much obliged!). I know HIP support is known to be missing or can be very delayed on some products, especially APU’s and budget HW.

Finally, mesa-libOpenCL likes to give rocm-comgr some issues (required by rocm opencl and hip). I don’t really have any insight right now other than to suggest removing mesa-libOpenCL if you don’t need it.

2 Likes

Awesome to know you, @mystro256 ! Thanks for introducing yourself on this thread. I can’t seem to get enough information about this, so I’m glad you posted.

You said, “Fedora’s stable LLVM might be at most 6 months on hardware support.” I assume you meant “at most 6 months behind on hardware support”, is that right?

This is all good information and is nearly what I’ve pieced together, myself, the hard way. I glad to hear about LLVM 16. Will that come to F37? I’m guessing not.

Yes, I would love to know more about HIP. I don’t use it, but I would like to play with it, some day, and people elsewhere have asked about it and I never know how to help them.

Regarding support, I would be happy to be contacted to test things. I’ve been OpenCL crunching for 24 years with Fedora, and with AMD GPU since whenever they bought ATi. So, I’m personally heavily invested in it. I don’t think of myself as on the cutting edge, but I often find myself trying to get new-ish hardware working. And I’m thrilled things are getting easier on Fedora, little by little.

Thanks! Yes I meant up to 6 months behind. It depends on where we are in the LLVM release cycle, which is every spring and autumn. So Fedora’s lag on HW support can vary up to 6 months at worst, but near zero at best.

I doubt f37 will get LLVM 16 because upgrading LLVM is a lot of work, and so usually they only backport it to one fedora version (it originally landed in rawhide/f39).

If you want to play with HIP, I’m told blender has support for it. I’m really new to HIP too, so I’m still trying to figure it out a bit.

If you can, I have an opencl update here:
https://bodhi.fedoraproject.org/updates/FEDORA-2023-68012d0819

I’m not sure if you can subscribe to package updates or not, but you can leave positive and negative reviews. It fixes a few bugs from the update to 5.5.0.

Cool! Yes, I can test pkgs in updates-testing, that’s easy! Looks like you fixed darktable, that’s great. I know many people use that.

Yes, if you search for Blender on the forums, you’ll find the help requests I’m speaking about. AFAIK, it hasn’t worked with Fedora (without AMDGPU-PRO), ever. Also, AFAIK, -PRO hasn’t worked in years, since the new installer that hasn’t been broken to work on Fedora. (I used to be easy to cheat, but now it’s harder. If I wanted -PRO, though, I wouldn’t be using Fedora.) But, as I say, I don’t use Blender or HIP, just old OpenCL, so I could easily be wrong. There are HIP RPMs in -PRO repos that will install along Fedora’s base AMDGPU & ROCm support, but I cannot be sure that works. I just know HIP+Blender (& similar) keeps coming up whenever I visit the forums to post about my OpenCL issues with AMDGPU+Fedora.

looks like your update has already passed karma and got pushed out. I have F38, now, and I got several ROCm 5.5.0 pkgs.

Hey, @mystro256. I’m having a lot of problems with my 7900 + OpenCL on Fedora. The system is too unstable to even use. I don’t seem to have problems with games, but when I crunch Einstein@Home, it crashes frequently.

You mentioned something about LLVM16 in F38. I upgraded to F38, which went well. I now have LLVM16 as the main LLVM, but I still have LLVM v15 (llvm15-libs pkg). RPM says nothing requires llvm15. Since my symptoms didn’t improve between F37 and F38, with the new LLVM, do you think it’s possible that there is a problem with LLVM15 + RDNA3 (but not RDNA2–my 6800XT works fine in the same system) and that ROCm-OCL is using LLVM15 on my system?

Okay, I’ve confirmed it that some one is using a 7900 for my same OpenCL application and it is working fine…on Ubuntu LTS with the official AMD driver installer. So, that means this issue is the driver stack in Fedora 38. I don’t know if it’s ROCm or AMDGPU or both, but it’s in there.