Resolving kernel panic

My wife’s laptop ran out of power and shut down during the installation process.

On restart the following message was encountered:

/initramfs-5.19.4-200.fc36.x86_64.img not found

From the grub boot menu it is possible to log into older kernels and into recovery mode. I would appreciate step-by-step guidance on how to resolve this please. Thank you.

I suggest that you boot into an older kernel and dnf reinstall the new one. Also run dnf check to make sure you don’t have any other issues.

Sudo dnf check did not report any issues. I ran dnf reinstall and rebooted but still had the same outcome. What steps should I try next?

You may need to uninstall that kernel then reinstall it so it gets properly configured.
sudo dnf remove kernel*5.19.4*
sudo dnf upgrade --refresh

Thank you. I have tried that but still get the same message. Could grub be part of the issue? The error message begins “error: …/…/grub-core/fs/fshelp.c:257: file ‘/initramfs-5.19.4-200.fc36.x86_64.img’ not found.”

That file should be here

[root@newbox ~]# ls -l /boot/initramfs-5.19.4-200.fc36.x86_64.img
-rw-------. 1 root root 25205013 Aug 29 08:22 /boot/initramfs-5.19.4-200.fc36.x86_64.img
[root@newbox ~]# 

It should be referenced from

[root@newbox ~]# cat /boot/loader/entries/b4146134cc534b2bb35b75e467b91eb4-5.18.19-200.fc36.x86_64.conf
title Fedora Linux (5.18.19-200.fc36.x86_64) 36 (Xfce)
version 5.18.19-200.fc36.x86_64
linux /boot/vmlinuz-5.18.19-200.fc36.x86_64
initrd /boot/initramfs-5.18.19-200.fc36.x86_64.img
options root=UUID=56a83e29-1e98-44f6-a33e-8988906ef2a1 ro rhgb quiet
grub_users $grub_users
grub_arg --unrestricted
grub_class fedora
[root@newbox ~]# 

If your system does not show the same (except from the value of the UUID) I would think that the reinstall failed with a message.

Can you see if /etc/kernel/cmdline exists and is missing ro rootflags=subvol=root

For reference, Fedora error | Kernel 5.18.18 - #2 by grumpey


Thank you all for your help - much appreciated. Issue resolved, and my wife’s laptop updated to 5.19.6.

1 Like

Hi! @maverickofsurrey

Could you please mark what TOPIC help you to resolve your Issue or Steps which you did to resolve your issues, in this way other people/person with the same problem can read your answer and easily answer their question if they have the same problem.



To clarify what did help:

  1. Log in selecting working kernel build at grub menu
  2. At command line: sudo dnf remove kernel5.19.4
  3. At command line: sudo dnf upgrade —refresh

I am still making use of the command line to update my wife’s laptop; problems are encountered whenever trying to update via the software store’s graphical interface.

I should add that running sudo dnf clean and sudo dnf autoremove don’t appear to make any difference.