Repeated authentication requests (Microsoft Team Foundation Server know as TFS)


i noticed an issue happening only with Fedora ( work fine on ubuntu, mint )

The problem is simple, when i use a browser to authenticate to microsoft TFS
i keep getting asked for password even if the user/pass are correct.

it’s just an endless loop of repeated authentication requests from the webpage

i feel like this is an issue from the authentication mechanic used in Fedora

any idea how to fix or any work around ?

“A browser”?

There is something about the authentication that needs further explanation.
What is involved? What’s happening underneath? Which browser, which protocols, and which ports? Sorry … I may be naive but … eh … what’s TFS?

The issue occur under Firefox ( Version 75 ) with Fedora 31
i tried with IceCat on the safe fedora and its working fine
i also tried with firefox in safe mode and i ran is the exact same issue

about the authentication method, i can’t tell,

TFS is the hosted version of Azure DevOps

about the auth method, i have no idea