Remove autoconnect to vpn using terminal

I’m using Fedora 34 and i think i broke my workstation on last update because as of right now mines stuck on boot sequence and i had to use tty2 to login but i cant sudo dnf history undo due to lack of internet access i cannot ping my router too after some digging i found out that my ethernet wont connect due to vpn auto connect was enabled but since im stuck in tty2 bash terminal nm-connection-editor wont load since theres no gui… is there a way to remove vpn auto connect solely imterminal and without any thirdparty packages since i cant even ping or my router… thanks

I am not in front of my machine to give you the exact commands but you can use nmcli to manage network manager from the command line.

Nice example from @vgaetera

1 Like

You can use a different kernel from the boot loader, usually, Fedora keeps 3 kernel versions. Just start your system, then when it start showing the boot loader (grub) choose non-default kernel option from the menu.

was able to connect the ethernet with nmcli thanks to @dalto but after trying different ways like sudo dnf history undo <id> no improvement, tried the 3 different kernels saved up but no luck, tried to downgrade to Fedora 33 just to see what happen but i’ve encountered an error that lead me to a dead end, when trying to sudo dnf system-upgrade reboot it shows missing shared file something after much research and found the same questions in stack overflow, i’ve decided to install a fresh Fedora 34 after backup of my encrypted partition.

based from my research there are Fedora users who encountered this based from unresolved questions and long threads from other forums, this goes to show that even though Fedora has been stable to me since Fedora 30 there are some cases of this throughout the years since there are unanswered post in stack overflow way back 2016 with same issue.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.