Remote Desktop Gnome 42 to Android Tablet

I’m trying to use the Remote Desktop sharing to extend my laptop screen to my Android Tablet.
I tried enabling the sharing on Gnome but cannot connect with Microsoft Remote Desktop App on Android. Can someone explain clearly which username to use? The app seems to indicate that the username should be user@domain or domain/user, but the sharing settings speak of just a simple username.
The app mentions gateway settings. Why is this necessary when both devices are configured correctly to connect to the network?
Any help would be appreciated.

1 Like

RDP is the microsoft protocol while linux uses VNC to connect to a remote desktop.
For this you need the VNC server running on the device you want to connect to.

TigerVNC :: Fedora Docs

I read through the document and it is not clear what is the display number that I should use. I’m trying to extend my desktop to the vnc client on the tablet in this case.

I know that it’s been a half year since you asked, but when I tried to accomplish same setup I found out this thread in google.
(I’m connecting laptop with Fedora 36 desktop to DumbTV through HDMI, and wished to control it with my android phone without leaving a couch)
First of all @ilikelinux sugested VNC, and it’s a solution… old one solution.
Yes it was recommended through years, but it doesn’t work with Wayland. The same reason is why teamviewer, anydesk etc. won’t work.
You can still use it by switching from Wayland to X, what is easy btw (you can just choose it before startup on login screen).
However X has pros and cons.
It’s getting old, it’s why Wayland is even developed.
Wayland is fresh by contrast and not everything is Wayland compatible yet.

But comming back to your question.

  1. Go to: Settings → Sharing
  2. Turn on in right upper corner
  3. Go to: Remote Desktop
  4. Turn on: Remote Desktop & Remote Control
  5. In Authentication set a user name and password for rdp
  6. In Remote Desktop Adress you have something like:

Everything is ok here.
Now download some RDP app for Android.
(I tried out Remote Desktop Menager and it works fine)
Just used fedora.local as host name, username that was set in Remote Desktop setting as username, and password that was set in Remote Desktop setting password as password.

All devices where in same wifi network.
Otherwise it would need public IP, VPN, or something.

I hope that when somebody would come here by googling, my answer would save him time I already lost to find out that it’s how to do it.

1 Like

On Android I’m being asked for more information:
Name: fedora
Folder: (I left it blank)
Host: Custom/Linked(vault)
Host: fedora.local - tried changing it to my local ip address
Port: I left it at the default setting
RDP type: Normal/Azure Cloud services/Hyper-V
Domain: ???
It is not working.

Make sure you use the exact password you typed in the sharing window, because it is completely separate (and in a different format) from a unix password.

Unfortunately, the MS RDP app doesn’t support zeroconf, and it doesn’t support server-set resolution (it sends the command containing the resolution, which will not be set by Gnome RD), so unless the server already uses the exact resolution (custom resolution in the app has to have same aspect as the device), the frame will be drawn out of sync.