Reboot stuck in "Failed to allocate manger object"

I managed to solve the problem following the SELinux guide on Fedora that you suggested but I need to first clarify what happened in case someone else faces a similar issue in the future. Prior to the issue with SELinux I had installed a VPN client package straight from a vendor which when I deleted I did not do a good job and left some hanging symlinks and also a few service files that started scripts that no longer existed. Upon booting that caused an issue with those hanging service and symlink files that caused the boot to hang with service failures. That was the initial problem.

After looking in the discussion section I followed with the nuclear solution of sudo dnf reinstall $(rpm -qa --qf "%{NAME}\n") --skip-unavailable from My Fedora workstation doesn't boot because we both had the same error message with the upower.service. Unfortunately for me because I could not even boot into rescue mode I had chrooted into my installation from a live ISO. This was mistake number two. Reinstalling everything from chroot will cause file context mismatches for systems with SELinux enabled and set in enforcing mode. This is how I ended up with the issue that iposted here originally.

Now to the solution. From the live iso I chrooted into the system and I first edited the /etc/selinux/config by changing the SELINUX=enforcing to SELINUX=permissive and then followed the options to allow automatic filesystem relabeling in the next system reboot. Before rebooting using journalctl -u [hanging service name].service I investigated the error messages for every hanging service from the latest boot which led to find the broken symlink of service files and the real service files that tried to start missing scripts. These I deleted entirely. After doing so I rebooted which solved the SELinux issue but I had to chroot back a few times to clean/delete some further simlinks from the initially deleted app that were still present. That ended up entirely fixing my problem and was able to properly boot into my system. In the end I did a normal system upgrade and everything was good. This small trip definitely taught me a lot.

Last, my takes on this for the future and some advice. 1) When installing not from the official repos inspect what was installed in your system and when deleting stuff make sure you clean everything left behind otherwise you might end up with broken dependencies (use dnf or rmp when deleting stuff not from official repos and still check for broken dependencies). 2) If you even decide to do system upgrades inside a chroot with a system that has SELinux enabled make sure you perform the system relabeling afterwords by following the guide from Changing SELinux States and Modes :: Fedora Docs otherwise you risk or most certainly will end up with a booting issue.