Reboot problem after upgrading to FC32

Hi all,
yesterday I upgraded some of my VMs from FC31 to FC32. It worked fine for all but one of them, but this one didn’t boot. So I decided to boot into “rescue” mode and it worked fine. I’m also able to boot directly into the default target (graphical).

So I thought something is wrong with “grub” configuration and I re-generated it using “grub-mkconfig”, but it didn’t change anything.

Next I added “” to GRUB_CMDLINE_LINUX in /etc/default/grub and again re-generated my grub configuration. Again, no success.

The VM only boot when ENTERING the mode where I can change boot parameters. It even boots if I don’t change anything, but I have to enter the edit mode.

Does anyone have an idea what I could do to solve the problem?

Post the output:

lsblk -o +FSTYPE,UUID; cat /etc/default/grub; grep -v -e ^# -e ^$ /etc/fstab
[root@svl0049 default]# lsblk -o +FSTYPE,UUID
sr0                     11:0    1  1024M  0 rom                         
xvda                   202:0    0   200G  0 disk                        
├─xvda1                202:1    0     1G  0 part /boot      ext4        e36829de-cd22-499a-84ea-92659a7d71c8
└─xvda2                202:2    0   199G  0 part            LVM2_member CpvFjC-eknv-uxVW-iFJ5-TIdn-QT6y-c1Qo
  ├─fedora_foobar-root 253:0    0    50G  0 lvm  /          ext4        e3d100a9-d4dc-4e0e-9168-3189a32bade2
  ├─fedora_foobar-swap 253:1    0   2.2G  0 lvm  [SWAP]     swap        ddf352cc-e546-4b88-9895-ac3458e91055
  └─fedora_foobar-home 253:2    0 146.8G  0 lvm  /home      ext4        59ae99ae-b75c-4133-8493-ab64b606c108
xvdb                   202:16   0    20G  0 disk                        
└─xvdb1                202:17   0    20G  0 part /tmp       ext4        a0638564-1a35-49fb-b82a-7a4589c8d81c
[root@svl0049 default]# cat /etc/default/grub; grep -v -e ^# -e ^$ /etc/fstab
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_CMDLINE_LINUX=" rhgb quiet systemd.unit=multi-
/dev/mapper/fedora_foobar-root /                       ext4    defaults        1 1
UUID=e36829de-cd22-499a-84ea-92659a7d71c8 /boot                   ext4    defaults        1 2
/dev/mapper/fedora_foobar-home /home                   ext4    defaults        1 2
/dev/mapper/fedora_foobar-swap swap                    swap    defaults        0 0
/dev/xvdb1 /tmp                                        ext4    rw,nosuid,exec,async,nouser,strictatime,nodev
1 Like

Try to enable the BLSCFG:

sudo grub2-editenv create
sudo grub2-switch-to-blscfg

Also, try to collect the log to identify the exact cause of the issue.

In addition, you can try to reinstall GRUB:
Restoring the bootloader using the Live disk

As well as use the following troubleshooting:

# Reconfigure GRUB
sudo grub2-editenv create
sudo grub2-mkconfig -o /etc/grub2$(test -d /sys/firmware/efi && echo -efi).cfg

# Regenerate all initramfs
sudo dracut -f --regenerate-all

# Enforce file system check
sudo touch /forcefsck

# Enforce SELinux relabelling
sudo touch /.autorelabel

# Reboot

Enabling BLSCFG did the trick! Thanks for your support.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.