Realtek Ethernet not working on 32

I recently built a workstation and fedora doesnt recognize the ethernet, on windows 10 works fine.

My motherboard is TUF GAMING B550M-PLUS (WI-FI)|Motherboards|ASUS Global

$ lspci | grep -i ethernet
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 04)

I tried installing the driver from
but it did not work.

Should I wait for future kernel and hope they would support this module?

Thanks in advance.

Hi @x59102 and welcome to the forum!

That chip should be covered by the r8169 driver. Can you check if it is loaded with

$ lsmod | grep r8169

and if that does not return anything, try loading it with

$ sudo modprobe r8169

thank you for replying.

$ lsmod | grep r8169
r8169 98304 0

didnt work after log off and reboot

“did not work” is very vague.

Out of interest, what does nmcli -p device status yield?

I’ve had a few recent installations recognize the card fine, but somehow didn’t come OOTB autoconnecting to Ethernet.


thank you for thee reply,

it “did not work” as in fedora didn’t recognize the adapter

Screenshot from 2020-07-09 08-12-32|690x483

$ nmcli -p device status

Status of devices


wlp4s0 wifi connected botnet_5G
p2p-dev-wlp4s0 wifi-p2p disconnected –
lo loopback unmanaged –

So I got the same issue on a new B550 chipset motherboard, I could only get it working by compiling the driver from the Realtek site.

    sudo lspci -nnvs 2a:00.0
2a:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller [10ec:8125] (rev 04)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:7c94]
	Flags: bus master, fast devsel, latency 0, IRQ 89
	I/O ports at e000 [size=256]
	Memory at fcb00000 (64-bit, non-prefetchable) [size=64K]
	Memory at fcb10000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable+ Count=1/1 Maskable+ 64bit+
	Capabilities: [70] Express Endpoint, MSI 01
	Capabilities: [b0] MSI-X: Enable- Count=32 Masked-
	Capabilities: [d0] Vital Product Data
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [148] Virtual Channel
	Capabilities: [168] Device Serial Number 01-00-00-00-68-4c-e0-00
	Capabilities: [178] Transaction Processing Hints
	Capabilities: [204] Latency Tolerance Reporting
	Capabilities: [20c] L1 PM Substates
	Capabilities: [21c] Vendor Specific Information: ID=0002 Rev=4 Len=100 <?>
	Kernel driver in use: r8125
	Kernel modules: r8169, r8125

But from another thread they point to only just being commited, looking at the exiting F32 module you only see reference to Rev A

modinfo r8169 | grep 8125
firmware:       rtl_nic/rtl8125a-3.fw
alias:          pci:v000010ECd00008125sv*sd*bc*sc*i

So suspect will have to wait till it drops in the kernel here?

That patch will be in kernel 5.9, which should be released later this year.

1 Like

Hi guys, new to Fedora, but @lcts does this mean that I will not be able to get this realtek network adapter to load in Fedora 31 until that kernel is released?
I have bought another network adapter that uses the RTL8168 chip and it is not showing up in the system at all.

1 Like

Yes. Here’s a nice site that tries to guess when that will be, based on release history: PHB Crystal Ball

The added support is currently in the kernel’s development branch, linux-next. There are no packages of that in Fedora. Once 5.9 hits the mainline branch (after 5.8 is released), you can try it out via Fedora’s Kernel Vanilla Repositories.

Or, if you’re feeling slightly adventurous, you can look into building your own kernel from the linux-next branch.

1 Like

@x59102 @timbucko FWIW, it looks like the Debian peeps got a DKMS package set up; installing it might be as “simple” as:

sudo dnf install @development-tools dkms
ar p r8168-dkms_8.048.03-1_all.deb data.tar.xz | sudo tar x -J -v -C / ./usr/src/
sudo dkms install r8168/8.048.03

It seems to have worked on my machine, though I can’t actually confirm since I don’t have that adapter.

[If this actually works on your end, hit the button to mark this as “solved” so people in the future can stumble across it more efficiently while we wait for Fedora devs to integrate it]

Thanks for this

I have confirmed this but with the 8125 driver from Realtek (Realtek PCIe FE / GBE / 2.5G / Gaming Ethernet Family Controller Software - REALTEK) its is working fine and been through a few kernel updates

    $ dkms status
    r8125, 9.003.05, 5.7.12-200.fc32.x86_64, x86_64: installed
    r8125, 9.003.05, 5.7.14-200.fc32.x86_64, x86_64: installed
    r8125, 9.003.05, 5.7.16-200.fc32.x86_64, x86_64: installed
  1. Insure make,gcc,kernel-devel,dkms installed

  2. Download driver from RealTek (there are a couple of unoffical downloads)

  3. From the zip, extract the …/src dir to /usr/src/r8125-9.003.05

  4. Add dkms.conf to this dir

    cat dkms.conf

Will look like

ls /usr/src/r8125-9.003.05/
dkms.conf  r8125_dash.h  r8125_n.c        rtl_eeprom.c  rtltool.c
Makefile   r8125.h       r8125_realwow.h  rtl_eeprom.h  rtltool.h
  1. Add the module sudo dkms add -m r8125 -v 9.003.05
  2. Build to check no issues sudo dkms build -m r8125 -v 9.003.05
  3. Install sudo dkms install -m r8125 -v 9.003.05

Now that 5.8 is released, those repos do in fact have packages for 5.9. There’s also a build in rawhide here.

Can confirm, I am now using 5.9.0-0.rc2.1.vanilla.2.fc32.x86_64 and the ethernet is working fine.

Thanks for all your help!

1 Like

Your dkms.conf didn’t work for me, at least on 5.8.7-200, so I grabbed dkms from an ubuntu repo (realtek-r8125-dkms/dkms.conf at master · awesometic/realtek-r8125-dkms · GitHub) , combined it with yours, and it built properly:

[ $PROCS_NUM -gt 16 ] && PROCS_NUM=16
MAKE="'make' -j$PROCS_NUM KVER=${kernelver} BSRC=/lib/modules/${kernelver} all"
CLEAN="'make' clean"

In regards to woolsgrs’ post: make sure you replace the double quotes with proper "
I got it built on 5.8.12-200.fc32.x86_64 with this little change.
There was no need to take the github changes for me.
The error I’ve got at first was:
Error! Build of “r8125”.ko failed for: 5.8.12-200.fc32.x86_64 (x86_64)
but the quotes didn’t look right.

Hope that helps someone.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.