Read-only disk in dual-boot


I am using dual-boot: Windows and Fedora 31. Last week I’ve reinstalled my Windows partition from Windows 7 to Windows 10, fixed grub via a Live USB, and now I can dual-boot again.
I have a few NTFS partition that I use as storage for both operating systems for years. However, now in Fedora I’ve noticed that the mounted drives are read-only. Whenever I try to save something on them in Fedora I get the error:

You are trying to save the file on a read-only disk.

I am mounting my disks on start-up via Disks on /mount/NAME_X. I can access all the files, but can’t write to the disk.

So this happened only after I have re-installed my Windows partition.

Any ideas?

1 Like

Fixed the problem :slight_smile:

Running ntfsfix twice(even though running it only once probably is enough), and then re-mount.

[xxx@wasteland ~]$ sudo ntfsfix /dev/sdd2
[sudo] password for xxx: 
Mounting volume... The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Attempting to correct errors... 
Processing $MFT and $MFTMirr...
Reading $MFT... OK
Reading $MFTMirr... OK
Comparing $MFTMirr to $MFT... OK
Processing of $MFT and $MFTMirr completed successfully.
Setting required flags on partition... OK
Going to empty the journal ($LogFile)... OK
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sdd2 was processed successfully.

Second time running it:

[xxx@wasteland ~]$ sudo ntfsfix /dev/sdd2
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sdd2 was processed successfully.

Unfortunately it looks like the problem is not solved. After booting to Windows yesterday, today coming back to Linux I have the same problem.

Do I have to run the ntfsfix command every time I log in? Should I make a startup scripts from this?

It’s very annoying. I think Windows 10 does something shady to the partitions when it shuts down :frowning:

You will probably need turn off fastboot in windows 10 into energy options. Look into google how turn off fast boot in Windows 10. If not the disk will not go completely off when you did poweroff windows


Its usually best practice to unplug your other drives. Windows is super aggressive during install and will break your other OS’s

@xtym I think you are right. I’ve googled it, turned it off and now it seems the problem is solved. Thanks for the tip. I’ll accept your answer for now. Let’s hope I don’t have to come back and change it :slight_smile:

1 Like

Normally I say to use the open source Linux solutions for everything however in this case I would encourage you to consider something else. Though it has been several years, when I was working in the seismic industry and was regularly mounting external NTFS formatted hard disks and transferring large contiguous files to our cluster and nas storage devices we found the built in NTFS driver Linux offers problematic. Our other option was doing transfers through windows which had significant issues working with our storage systems. We ended up using a third party NTFS driver from paragon software. It was significantly more robust and stable. As I recall it was also relatively inexpensive. It looks like they now charge $39. Perhaps this might be useful.
Oh, looks like you already fixed it. Nevermind.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.