Razer Blade 14, Fedora 36, Wifi not available

Razer Blade 14, amd 6900HX, nvidia 3070ti
Fresh install of Fedora36 + dnf upgrade

$ uname -r

$ lspci | grep -i network
02:00.0 Network controller: Qualcomm QCNFA765 Wireless Network Adapter (rev 01)

$ nmcli radio all
missing enabled missing enabled

$ dmesg | grep ath
[    4.188837] systemd[1]: systemd-ask-password-console.path - Dispatch Password Requests to Console Directory Watch was skipped because of a failed condition check (ConditionPathExists=!/run/plymouth/pid).
[    4.188893] systemd[1]: Started systemd-ask-password-wall.path - Forward Password Requests to Wall Directory Watch.
[    4.194207] systemd[1]: auth-rpcgss-module.service - Kernel Module supporting RPCSEC_GSS was skipped because of a failed condition check (ConditionPathExists=/etc/krb5.keytab).
[    4.795441] ath11k_pci 0000:02:00.0: BAR 0: assigned [mem 0xfc200000-0xfc3fffff 64bit]
[    4.795457] ath11k_pci 0000:02:00.0: enabling device (0000 -> 0002)
[    4.797712] ath11k_pci 0000:02:00.0: MSI vectors: 32
[    4.797718] ath11k_pci 0000:02:00.0: wcn6855 hw2.1
[    6.058829] ath11k_pci 0000:02:00.0: chip_id 0x12 chip_family 0xb board_id 0xff soc_id 0x400c1211
[    6.058834] ath11k_pci 0000:02:00.0: fw_version 0x11090c35 fw_build_timestamp 2022-04-18 20:23 fw_build_id WLAN.HSP.1.1-03125-QCAHSPSWPL_V1_V2_SILICONZ_LITE-3.6510.9
[    6.082263] ath11k_pci 0000:02:00.0: failed to fetch board data for bus=pci,vendor=17cb,device=1103,subsystem-vendor=11ad,subsystem-device=a82d,qmi-chip-id=18,qmi-board-id=255 from ath11k/WCN6855/hw2.1/board-2.bin
[    6.082266] ath11k_pci 0000:02:00.0: failed to fetch board.bin from WCN6855/hw2.1
[    6.082268] ath11k_pci 0000:02:00.0: qmi failed to fetch board file: -2
[    6.082269] ath11k_pci 0000:02:00.0: failed to load board data file: -2

Struggling with the Wifi not being available,
can some1 point me to a fix ?
If any more info is needed let me know.


We first need to know if the wifi adapter is seen and configured.
Please post the output of inxi -Fzx and ip address. rfkill may also assist.

Please use the </> Preformatted text tags when posting data from your screen so it retains the formatting you see and makes it easier to read. I took the liberty of editing your post above so you could see the difference in how it is displayed here.

@rebok232 , your 3 posts above ask for info he had already posted.

oh, sorry

but recents topic’s on forum’s are about wi-fi on 5.19.14

I watch this forum regularly and so far have not noted anything pointing to 5.19.14. Only specific wifi drivers and cards, and even then nothing showing an abnormal bump in problems encountered.

Regardless of the cause, enough info is needed to do troubleshooting and without info there is no way to identify what is happening. Please consider asking for details instead of pointing a finger at what may or may not be the actual cause.

Ok sorry


Tks for the reply.
Output requested(relevant parts I believe):

  Device-1: Qualcomm QCNFA765 Wireless Network Adapter vendor: Lite-On
    driver: ath11k_pci v: kernel bus-ID: 02:00.0
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB
    driver: r8152 bus-ID: 8-1.3:4
  IF: enp5s0f3u1u3 state: up speed: 1000 Mbps duplex: full mac: <filter>
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp5s0f3u1u3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:e0:4c:68:13:23 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute enp5s0f3u1u3
       valid_lft 85567sec preferred_lft 85567sec
    inet6 fe80::a72f:ff74:c09a:7b17/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
 0 bluetooth hci0   unblocked unblocked

try update
kernel 5.19.15 is out :slight_smile:

Updated kernel but still experiencing the issue :confused:

What about the output of lspci -nn | grep Qualcomm so we can see the actual chipset.

It seems the driver is loaded according to the inxi output, though it would have been appreciated if the full output had been posted so other related details may have been seen.

With the proper driver loaded you should be able to use the network settings panel and configure that interface. The gnome network settings is available either through the activities menu or by the icon in the upper right corner of the screen.

-2 means it cannot find board.bin
i checked and there’s not

I will try to find one for you

Don’t try renaming board-2.bin.xz cause it has other subsystem-vendor

update: still searching
it needs to be somewere
that is not even in official linux-firmware

If someone wants to help
we are searching


if someone has this file
ex. on the disk
that would be very good if that person would share it there

Follow this this could be helpful

This site Commits · kvalo/ath11k-firmware · GitHub shows updates thru Sept 19, 2022 so it may be necessary to update the driver. I don’t find a board.bin file on my system and do not have that Qualcomm board so cannot test. The error message seems to indicate it should be the same location as the board-2.bin file.

What if you tried linking ln -s /usr/lib/firmware/ath11k/WCN6855/hw2.1/board.bin.xz /usr/lib/firmware/ath11k/WCN6855/hw2.0/board-2.bin.xz. That would avoid renaming and would have the other file name for testing. It may work and should not harm, although it may change the error message. It also might be worth testing in linking board.bin.xz to each of the other files in …/hw2.0/ as well with various iterations if the first try does not work. Specifically amss.bin.xz, m3.bin.xz and regdb.bin.xz, though the latter would be my last guess.

I found that all the files in hw2.1 actually are links to the files in …/hw2.0/ anyway, and that all were last updated with a Sep 29 date. They likely contain all the updates of that firmware from the Sept 19th commit.

$ ls /usr/lib/firmware/ath11k/WCN6855/hw2.1/
amss.bin.xz  board-2.bin.xz  m3.bin.xz  regdb.bin.xz

$ ls /usr/lib/firmware/ath11k/WCN6855/hw2.0/
amss.bin.xz  board-2.bin.xz  m3.bin.xz  Notice.txt.xz  regdb.bin.xz

$ ls -l /usr/lib/firmware/ath11k/WCN6855/hw2.0/
total 1764
-rw-r--r--. 1 root root 1665096 Sep 29 08:35 amss.bin.xz
-rw-r--r--. 1 root root   15408 Sep 29 08:35 board-2.bin.xz
-rw-r--r--. 1 root root  105872 Sep 29 08:35 m3.bin.xz
-rw-r--r--. 1 root root   12000 Sep 29 08:35 Notice.txt.xz
-rw-r--r--. 1 root root    2132 Sep 29 08:35 regdb.bin.xz

$ ls -l /usr/lib/firmware/ath11k/WCN6855/hw2.1/
total 0
lrwxrwxrwx. 1 root root 20 Sep 29 08:35 amss.bin.xz -> ../hw2.0/amss.bin.xz
lrwxrwxrwx. 1 root root 23 Sep 29 08:35 board-2.bin.xz -> ../hw2.0/board-2.bin.xz
lrwxrwxrwx. 1 root root 18 Sep 29 08:35 m3.bin.xz -> ../hw2.0/m3.bin.xz
lrwxrwxrwx. 1 root root 21 Sep 29 08:35 regdb.bin.xz -> ../hw2.0/regdb.bin.xz

You can’t use orginal board-2.bin.xz file here
cause kernel is searching other subsystem vendor

i changed subsystem vendor board-2.bin.xz in ghex
and here:
you can download it

You can rename it

replace files in /usr/lib/firmware
to do it
open nautilus
click ctrl + l
and type admin:/usr/lib/firmware/ath11k/WCN6855
now just move orginal board-2.bin.xz file
and paste one mega

don’t forget to change symlinks

I suspect that since the only thing you did with that file was to uncompress it from board-2.bin.xz to board-2.bin your approach may not work. (a shaw256sum shows the uncompressed file and the downloaded file are identical). The system expects to be working with a compressed (.xz) firmware file; which is why all the provided files are xz compressed.

Further investigation shows that the amss.bin.xz file is a 32 bit elf executable for Arm, and the m3.bin.xz file is a 32 bit elf executable for x86. The board-2.bin.xz and regdb.bin.xz files are both binary data.

02:00.0 Network controller [0280]: Qualcomm QCNFA765 Wireless Network Adapter [17cb:1103] (rev 01)

Tks for the link.
Unfortunately did not solve the problem :confused:

Did you tried replacing board-2.bin.xz and changing symlink?

Yes, no luck unfortunately.
Is it a good ideia to report this on fedora bugzilla ?