Rawhide Booting for 2 Hours

A. I upraged to fedora 33 from 32 via dnf… After rebooting the upgrade it loads all services then gets stuck for 2hours. then it loads the GDM.

B. I decided why not start afresh… Installed fresh copy of rawhide. Worked fine first 2-3 boots…
I wast trying to figure out what is causing the delay in boot time so I was installling packages and rebooting. On an instance I installed gtk4 then it took 2 hours to reach GDM login screen. I did a fresh install and tried installing chromium also when I reboots it takes long

The only propblem being reported by the bootolog is

[FAILED] Failed to start Virtual Machine and Container Registration Service.
See 'systemctl status systemd-machined.service' for details.

systemctl status systemd-machined.service

● systemd-machined.service - Virtual Machine and Container Registration Service
     Loaded: loaded (/usr/lib/systemd/system/systemd-machined.service; static)
     Active: failed (Result: exit-code) since Tue 2020-08-04 13:39:15 CAT; 2h 38min ago
       Docs: man:systemd-machined.service(8)
    Process: 668 ExecStart=/usr/lib/systemd/systemd-machined (code=exited, status=1/FAILURE)
   Main PID: 668 (code=exited, status=1/FAILURE)
        CPU: 51ms
Aug 04 13:39:14 fedora systemd[1]: Starting Virtual Machine and Container Registration Service...
Aug 04 13:39:14 fedora systemd-machined[668]: Failed to bind to varlink socket: Permission denied
Aug 04 13:39:14 fedora systemd-machined[668]: Failed to fully start up daemon: Permission denied
Aug 04 13:39:15 fedora systemd[1]: systemd-machined.service: Main process exited, code=exited, status=1/FAILURE
Aug 04 13:39:15 fedora systemd[1]: systemd-machined.service: Failed with result 'exit-code'.
Aug 04 13:39:15 fedora systemd[1]: Failed to start Virtual Machine and Container Registration Service.

Why is it taking long to boot

1 Like

Most likely a SELinux issue.
You can verify this by setting SELinux to the permissive mode.
In any case, you should probably report this problem:

1 Like

Please check this wiki, as describe there

Rawhide is targeted at advanced users, testers and package maintainers.


Also this TOPIC



Thanks I had wanted to test it

I will set selinux on boot and see what happens

1 Like

It would be nice when you report a bug to buzilla https://bugzilla.redhat.com/ about this.

1 Like

I will learn how to report… Its that I dont know whats causing the problem… I did selinux=0 on boot the problem systemd-machined.service went but it still took 2 hours to boot. I will file a bug now

You do not need to know the cause of the problem to file a bug. File a bug and help us to make a better Fedora.

1 Like

Ok I have put the bug

@bretjoseph Thanks you for filing the bug.
If you really want to install Rawhide see https://www.happyassassin.net/nightlies.html for new versions of Rawhide. Maybe the new version will work fine.
Read https://docs.fedoraproject.org/en-US/fedora/rawhide/install-guide/install/Preparing_for_Installation/ for install. Use Fedora Media Writer.

I made a custom kernel from scratch and it boots fine, it seems the kernel vmlinuz-5.8.0-1.fc33.x86_64 has issues

@Bretjoseph I suppose the issue is ovr now?

but the is still a bug on the kernel though

@bretjoseph I did not update Fedora 33 today, so I can not confirm the kernel is still showing that bug. Did you upgrade to the new nightly Rawhide? And did you see that bug? Now you filed a bug report that bug will end soon.

the booting problem is over but the kernel still doesn’t login whether graphical target greeter nor multi-user target, kernel says something about it cant start sh. I can only log in when I disable selinux=0 on grub. When I try loging in, it brings the login prompt again

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.