Python - cannot install CoolProp

Dear Fedora users
I have a problem with install CoolProp using python pip. After typing

pip3 install CoolProp
I get output which I pasted at the end.
I tried:

dnf reinstall python3-pip
sudo dnf reinstall python3-pip
pip-3 install CoolProp
sudo dnf install python3-pip python3-idle python3-devel
pip install wheel
But nothing worked.
What can be a reason for this?
Here is a link for terminal output:

Can you please check what versions of Python CoolProp supports? We’re on Python 3.9 on Fedora 33 now. I don’t think it supports Py3.9. Your errors mention tp_print which is no longer in Python 3.9:

So, check what version of Python CoolProp supports, then create a virtual environment using that version of Python, and try your pip command there.

# if you need python 3.7:

$ sudo dnf install python3.7
# Create a virtual environment:
$ python3.7 -m venv .virtualenv
# Activate it and install there
$ source .virtualenv/bin/activate
$ pip install CoolProp

Next, if you can, also inform the CoolProp developers of the issue so that they can fix it.