ProOne 440 G5 does not work with Linux

We are trying to get Fedora:32 working on the ProOne 440 G5. We’ve also tested Ubuntu 20.04.1, but both distros don’t seem to work at all. The screen just cycles through RGB, white and black on boot. It looks 90% similar to this:

Linux will boot with the kernel mode setting (KMS) disabled (nomodeset), but this disables the GPU driver and dramatically decreases video performance as well as lowering the resolution and disabling the sound. We kinda need sound for our use-case.

Does anybody know how to get Fedora:32 working on this machine (or Linux in general)?


Have you tried disabling secure boot in the bios?

Thanks Tom.

Yes we have disabled Secure Boot, but we use Legacy Boot options for iPXE netboot.


I would try the bios settings listed here:

Thanks Tom.

We’ve tried the BIOS settings but they don’t seem to make a difference…

Is the latest BIOS firmware installed?

We’ve updated to the latest firmware (02.07.01 Rev.A).

One thing to note is that there are no BIOS downloads available on the official support site for any operating system other than Windows 10 editions: HP ProOne 440 G5 23.8-in All-in-One Business PC Software and Driver Downloads | HP® Customer Support