Problems with wayland after updating to fedora 39 - PART 2 - org.freedesktop.systemd1’ failed at login”

The firmware appears to be up to date. If I try to login as Wayland it will boot me out and set the default to X11. The GUI does not die, it just goes to X11. I can still get a terminal.

This is the update from journalctl -b -p 3. It seems to be relevant but I am not sure what it means.

Jan 10 17:36:18 fedora kernel: x86/cpu: SGX disabled by BIOS.
Jan 10 17:36:18 fedora systemd-vconsole-setup[293]: /usr/bin/setfont failed with exit status 71.
Jan 10 17:36:18 fedora systemd-vconsole-setup[546]: /usr/bin/setfont failed with exit status 71.
Jan 10 22:36:36 fedora kernel: Bluetooth: hci0: BCM: firmware Patch file not found, tried:
Jan 10 22:36:36 fedora kernel: Bluetooth: hci0: BCM: 'brcm/BCM20702A1-0b05-17cb.hcd'
Jan 10 22:36:36 fedora kernel: Bluetooth: hci0: BCM: 'brcm/BCM-0b05-17cb.hcd'
Jan 10 22:36:37 fedora kernel: ucsi_ccg 0-0008: UCSI_GET_PDOS failed (-70)
Jan 10 22:36:37 fedora kernel: ucsi_ccg 0-0008: UCSI_GET_PDOS failed (-70)
Jan 10 22:36:37 fedora kernel: 
Jan 10 22:36:38 fedora kernel: NVRM: loading NVIDIA UNIX x86_64 Kernel Module  545.29.06  Thu Nov 16 01:59:08 UTC 2023
Jan 10 22:36:38 fedora kernel: ucsi_ccg 0-0008: UCSI_GET_PDOS failed (-70)
Jan 10 22:36:39 fedora /usr/bin/nvidia-powerd[1488]: No matching GPU found
Jan 10 22:36:39 fedora /usr/bin/nvidia-powerd[1488]: Failed to initialize RM Client
Jan 10 22:36:42 fedora smbd[1869]: [2024/01/10 22:36:42.360628,  0] ../../source3/smbd/server.c:1746(main)
Jan 10 22:36:42 fedora smbd[1869]:   smbd version 4.19.3 started.
Jan 10 22:36:42 fedora smbd[1869]:   Copyright Andrew Tridgell and the Samba Team 1992-2023
Jan 10 22:36:42 fedora dbus-broker-launch[2135]: Ignoring duplicate name 'org.freedesktop.FileManager1' in service file '/usr/share//dbus-1/services/org.freedesktop.FileManager1.service'
Jan 10 22:36:43 fedora gnome-session-binary[2140]: Unrecoverable failure in required component org.gnome.Shell.desktop
Jan 10 22:36:57 fedora gdm-password][2796]: gkr-pam: unable to locate daemon control file
Jan 10 22:37:00 fedora dbus-broker-launch[2947]: Ignoring duplicate name 'org.freedesktop.FileManager1' in service file '/usr/share//dbus-1/services/org.freedesktop.FileManager1.service'

Ignore the message about nvidia-powerd. That is not relevant and is merely a message that the gpu card is not one that is supported by the nvidia-powerd.service. It is expected in many cases since the subset of nvidia GPUs that it is designed for is a relatively small group.

you would probably see this with the systemctl command.

# systemctl status nvidia-powerd.service
○ nvidia-powerd.service - nvidia-powerd service
     Loaded: loaded (/usr/lib/systemd/system/nvidia-powerd.service; enabled; preset: enabled)
    Drop-In: /usr/lib/systemd/system/service.d
     Active: inactive (dead) since Sat 2024-01-06 14:49:11 CST; 4 days ago
   Duration: 863ms
   Main PID: 1356 (code=exited, status=1/FAILURE)
        CPU: 5ms

Jan 06 14:49:10 eagle.home.domain systemd[1]: Started nvidia-powerd.service - nvidia-powerd service.
Jan 06 14:49:10 eagle.home.domain /usr/bin/nvidia-powerd[1356]: nvidia-powerd version:1.0(build 1)
Jan 06 14:49:11 eagle.home.domain /usr/bin/nvidia-powerd[1356]: No matching GPU found
Jan 06 14:49:11 eagle.home.domain /usr/bin/nvidia-powerd[1356]: Failed to initialize RM Client
Jan 06 14:49:11 eagle.home.domain systemd[1]: nvidia-powerd.service: Deactivated successfully.

And that message can be eliminated if you used sudo systemctl disable nvidia-powerd.service

1 Like

In my case, I cannot log in to Wayland. I don’t have root enabled. I can log in through Xorg, but many apps are not there, even gnome-terminal is not there! Is my system broken?

Long Description:
I recently installed Fedora 39 on Acer E5 475 with 32 GB of memory and Core i5 Gen 6 CPU.

At some point, my system froze and I had to forcefully shut down. Restarted and this happened.

Tried switching to other tty’s by pressing Ctrl+Alt+F2(F3, F4, F5, etc) and when I log in to my account, but in those accounts even “sudo” is not available. The system says “command not found” and asks me to confirm its install. When confirmed, the system stupidly tries to install the package but finds the app is installed already and reports so. Again, the app is not found if I try to execute it and so on and so forth. Fedora 39 is a mess!

This sounds like a broken installation which may not have completed correctly.

Please consider a reinstall to fix these serious problems.

But it was working fine for a couple of days after installation. I performed an upgrade and even then it was working. Then a freeze happened at some point and I powered it off. The mentioned problem was what came after.

The “freeze” could be due to a hardware failure. Did you try connecting to the “frozen” system with using a text console or ssh to see if the kernel was still alive?

Journalctl may have some details. If the freeze killed the linux kernel, the journal may not have any records for the time of the crash. A kernel crash can damage the filesystem. Booting a system after a crash should trigger a repair attempt, but some files may be corrupt. Journalctl has a -p N (priority) option, but some high priority errors are normal, so you need to compare errors between the current boot and one from before the freeze. You can also check for filesystem repairs (fsck) messages on the first boot after the freeze.

This thread had not been active since a while. I am also waiting for a fix of this issue. My system is updated nearly daily and since December there is no change for me: Gnome sessions under X11 work flawlessly, Gnome sessions under Wayland do not proceed beyond a black screen after login and fall back to the session manager. This is my Desktop system with NVidia drivers (RTX3060Ti).

I also have an older Laptop with Intel CPU embedded graphics. Here Gnome on Wayland works absolutely flawlessly. Some of te experts answered, that this is not a NVidia issue, but I still have doubts.

If there would not be the issue, that FC40 might abandon X11 completely, I would not worry too much…

The current f40 pre-Beta still has Gnome with X11 available. Maybe you need to install the package gnome-session-xsession to make it available.

I am also facing this issue for quite some time now and worry about the next fedora release.

The original poster’s issue was fixed with updates:

Other users may see similar symptoms, but there is no reason to assume the causes are the same. This thread requested details that might help find a solution. If you want a solution, start a new thread and provide (see examples for the same information requested in this thread):

  • output from inxi -Fzxx (run in a terminal and pasted as text using the </> button).
  • If you have Nvidia graphics, please also post (as text) the output from dnf list --installed \*nvidia\*.
1 Like