Problems launching Fedora

The computer is a HP laptop HP-14dk0002dx AMD A9-9425 Dual-Core Integrated AMD Radeon R5 Graphics and Realtek RTL8723DE 802.11b/g/n (1x1) and Bluetooth 4.2 combo, OS is Fedora Gnome

This is not my computer. They upgraded to Fedora 37 it boots and only gets to the fedora splash screen does not make it to the login screen and does a reboot loop unless I change to the kernel 6.0.

All the 6.1 kernels have this problem

I get this on the screen even with 6.0 and 6.1 kernels

I did a reinstall with 36 and 37 it boots and I do not get the message until I update then the same thing happens with 6.0 and 6.1 kernels

Does anyone know what this hardware error is?

Or is it something the update did?

That looks like a possible memory error.
Reinstall with a version that does not give the error. Then use a live boot memtest86+ device and run a thorough test of the ram. Let it run at least overnight to see what errors it will give. It may also be something else related to the CPU or memory or motherboard, but will require some testing to identify it.

One common thing that happens is a little bit of oxidation on the contacts of the RAM chip. That can often be fixed by simply removing the RAM chip and cleaning the contacts along its edge with an eraser, then reinstall it.


Finely had time to run memtest86
It ran for over 12 hours 7 passes with no errors
I even took them out and switched them around before the test
I even took the nvme and wifi out and back in before the test
What does not make sense to me is I do not get the hardware error with a live usb or a fresh install and it boots fine
It only happens after I update

Live USB or fresh install of F37 give no errors?
Or is it a live usb or fresh install of F36 with no errors but the upgrade to F37 gives the errors?

Both live USB and fresh install of both F36 and F37 give no errors
This is not my laptop
When they upgraded from F36 to F37 it must have pulled in the 6.1 kernel and they got the error and the boot loop
Had to use the 6.0 kernel boot into the desktop

The above thread suggest the firmware issues can cause MCE during boot.

I would suggest to first check with HP hardware forums to see if it is a common issue.

At the same time, try to identify if any specific Kernel version is working, stick to that version until a newer kernel works for you.

I notice that others are having trouble with the 6.1 kernel
Some mention that the boot stops at started wpa_supplicant.service
That is were mine stops at but goes into a boot loop
wpa_supplicant.service has something to do with the wifi I am not sure what or if it is connected with the kernel
So I removed the wifi card and bingo it boots to the login screen now with both 6.0 and 6.1 kernel
No hardware screen error, as above, or notification telling me a problem in a component has occurred
I did get the notification on first boot of the 6.1 kernel but after that no notification
Everything is working as it should boot after boot after boot with the wifi card removed
Reinstall wifi card problem comes back
I tried to remove wpa_supplicant but it wanted to remove a lot of stuff
I am not sure how to disable and reenable wpa_supplicant.service
If someone could show me how to do that, that would be great
The wifi does work with the problems and without the problems
So I don’t know why wpa_supplicant.service is stopping it from booting into the desktop
The wireless card is a Realtek RTL8723DE

It would be interesting to see if everyone with this error has a Realtek wifi adapter.

I would suggest that you gather all the info you have about the kernel, the wifi card, drivers, and the boot issue then file a bug report.
Since it works with the 6.0 kernel but not the 6.1 kernel(s) then it seems a regression in the kernel and would seem that a bug report is needed.

Masking and Unmasking Units

We saw in the service management section how to stop or disable a service, but systemd also has the ability to mark a unit as completely unstartable, automatically or manually, by linking it to /dev/null. This is called masking the unit, and is possible with the maskcommand:

sudo systemctl mask nginx.service

To completely prevent a service from running, use the mask sub command.