Problems installing/booting Fedora on Surface Laptop 3

I’m trying to install Fedora on a 15" Microsoft Surface Laptop 3. The boot is hanging very early.

What works:

  • Windows 10.
  • Booting Rescuezilla from a USB key. (Rescuezilla is based on Ubuntu).

What doesn’t work:

  • Booting an existing Fedora 38 install from an external SSD. This install works ok on two other laptops, so partitioning/grub/fstab of the SSD is all ok. What happens:

    • Screen shows the usual four white “Surface” squares.
    • SSD LED blinks for a second.
    • No further activity, even after an hour.
  • Booting a Fedora 39 netinstall USB key. This key works on other machines. What happens:

    • GRUB screen appears, with options to install Fedora 39, test and install, or do troubleshooting.
    • Selecting the install option clears the screen, which is then blank except for a non-blinking cursor in the top left corner.
    • No further activity, even after an hour.

I have turned off the Windows Boot Manager in the boot setup, and turned on support for 3rd party CA key in the secure boot settings, although the same thing happens regardless of these settings.

In GRUB, I’ve tried typing this:

linuxefi /images/pxeboot/vmlinuz
initrdefi /images/pxeboot/initrd.img

They work fine without error. Then I type boot. The cursor jumps to the start of the next line, and then nothing further happens, the machine is hung.

How can I find where the boot is hanging?

Have you tried the troubleshooting option and using basic graphics mode?