Problem with photo managers


Since migrating to Fedora 35, photo managers such as Darktable, Shotwell, and DigiKam no longer work properly. Crashing and very slow. It is striking that this software works well again when I start it as Root. With Fedora 34, I had no problems with that.

If you work with Gnome 41you have to take in consideration that the software you use is not ready for this version yet or still has bugs. Please search in internet with gnome 41as keyword and the software name.

Thanks for the quick answer. I have 3.42.0. I put the previous version back with grub2-set-default 1. Now it’s working again. Is this a wright solution for me?

Excuse me: 3.42.0 is referred to what?

1 Like

Maybe you could try with sudo dnf reinstall appname, and hopefully it will overwrite it. I have Darktable for light raw image editing, but it’s installed after my system upgraded to F35.

Maybe you also consider to run sudo dnf distro-sync.

Btw, I use Gnome Xorg session (since my laptop for media consumption using nvidia driver), I’m not sure if it will be same with wayland session (default gnome).

To the Gnome version.

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

Some I understand, some I don’t :slight_smile:

  Kernel: 5.15.8-200.fc35.x86_64 x86_64 bits: 64 compiler: gcc
  v: 2.37-10.fc35 Desktop: GNOME 41.2
  Distro: Fedora release 35 (Thirty Five)
  Type: Laptop System: LENOVO product: 20FJS1TQ00 v: ThinkPad T560
  serial: <superuser required>
  Mobo: LENOVO model: 20FJS1TQ00 v: SDK0J40705 WIN
  serial: <superuser required> UEFI-[Legacy]: LENOVO v: N1KET47W (1.34 )
  date: 12/13/2019
  ID-1: BAT0 charge: 38.0 Wh (96.9%) condition: 39.2/44.5 Wh (88.1%)
  volts: 12.4 min: 11.4 model: SONY 45N1743 status: Unknown
  Info: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP
  arch: Skylake rev: 3 cache: L2: 512 KiB
  flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 19200
  Speed: 2700 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 2700 2: 2700
  3: 2700 4: 2700
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915
  v: kernel bus-ID: 00:02.0
  Device-2: Lite-On Integrated Camera type: USB driver: uvcvideo
  bus-ID: 1-8:5
  Display: wayland server: X.Org compositor: gnome-shell driver:
  loaded: i915 note: n/a (using device driver) - try sudo/root resolution:
  1: 1600x1200~60Hz 2: 1366x768~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 21.3.2
  direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Sound Server-1: ALSA v: k5.15.8-200.fc35.x86_64 running: yes
  Sound Server-2: PipeWire v: 0.3.40 running: yes
  Device-1: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel
  port: N/A bus-ID: 00:1f.6
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel bus-ID: 04:00.0
  IF: wlp4s0 state: up mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb
  v: 0.8 bus-ID: 1-7:3
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 942.7 GiB used: 464.1 GiB (49.2%)
  ID-1: /dev/sda vendor: SunEast model: SSD SE800 512GB size: 476.94 GiB
  ID-2: /dev/sdb type: USB vendor: Toshiba model: MQ01ABF050
  size: 465.76 GiB
  ID-1: / size: 475.94 GiB used: 274.42 GiB (57.7%) fs: btrfs dev: /dev/sda2
  ID-2: /boot size: 973.4 MiB used: 270.1 MiB (27.7%) fs: ext4
  dev: /dev/sda1
  ID-3: /home size: 475.94 GiB used: 274.42 GiB (57.7%) fs: btrfs
  dev: /dev/sda2
  ID-1: swap-1 type: zram size: 8 GiB used: 482.8 MiB (5.9%) dev: /dev/zram0
  System Temperatures: cpu: 44.0 C pch: 39.0 C mobo: N/A
  Fan Speeds (RPM): fan-1: 2546
  Processes: 649 Uptime: 10h 32m Memory: 15.04 GiB used: 5.29 GiB (35.2%)
  Init: systemd runlevel: 5 Compilers: gcc: 11.2.1 Packages: 12
  note: see --pkg Shell: Bash v: 5.1.8 inxi: 3.3.09

As i mentioned in the beginning, Gnome Desktop: GNOME 41.2

Can you please be more specific?

Digikam, Darktable and Shotwell start normally, but click commands get little or no response and after a few seconds the software crashes and a message is sent to Fedora. It seems like I’m working on Windows again. Starting the app as root and restoring the kernel version solves everything. Other software like Remmina and Boxes no problems.

Darktable comes with a new version soon …

Now the same problems start with remmina. After I choose full screen, I don’t get the menu at the top anymore. I only get it when I run remmina as sudo. A little bit of trouble with Fedora isn’t a bad thing that comes with this concept, but this is starting to get annoying.

Since you can run the app correctly with sudo, would you like to try to create new user from Gnome Settings (or equivalent for KDE or other desktop environtment) then without any customization, please run again remmina on newly created user. Check if it still have same behavior or not.

Due to holidays, the answer is a little later.
I have created a new account and indeed, the menu bar appears again in remmina. Could Gnome be the cause of this?

Not sure, but you could reset it entirely your current user setting related to Gnome setting with mv /home/<yourusername>/.config/dconf/user /home/<yourusername>/.config/dconf/user.bak, then logout and login again. It will regenerate the user file again.

I did what you recommended, but this didn’t help. I tried again with Opensuse to see if this went better. This is more of a disaster than a solution. Quickly returned to Fedora with great difficulty. Sorry for this mistake ;-). Fedora 35 reinstalled and it’s back to normal. Next time just reinstall Fedora as a solution. Thanks for your help and still valuable advice. I certainly learned from it.

I edited post 8 and added the preformatted text tags so the output of inxi is readable as seen on your screen.

Note that reinstalling is usually not necessary. An (almost) identical fix could be had by doing sudo dnf distro-sync

1 Like

Thanks, I will remember it for a next time.

Since after you resetting the Gnome and the problem persist, it could be any custom local environment setting inside ~/.bashrc or related dot file or some broken custom gnome extensions.

But glad everything back normal now.

There have been problems again. Now the system no longer recognized an external HDD and the SD. Backups are a problem. Centos installed and the problems are over. The computer is not a hobby for me, but I work with it, so I leave it that way. Until the version 34 I was satisfied with Fedora, with the version 35 came the problems.

1 Like