Problem with clicking noise after running any Audio Media Players

I have this unusual problem that I cannot understand with fresh install upgrade to Fedora Design Suite 32. I installed some media players like:Clementine, Amarok, Banshee through Software application and/or dnf.
Bizarre problem with these players and also noticed the same when going online to You Tube and playing music there. When I first start playing anything through audio (Media Players or You Tube) I’ll hear a short double click, selected music will play okay yet when stopping the players or at the end of a song on You Tube and clicking back to menu after a short pause on start a clicking pulsing noise will start up and will not stop until I unplug the cable connected to the Stereo speaker (lime green) external audio jack connector. After moving this out and then re-plugging the noise will stop until I start using the Media Players again or at You Tube select another recording to play.

I have three other operating systems on this desktop computer (an older HP with Intel Pentium D CPU, 3.2 GB RAM, Radeon HD 5000 series R5 220 add on graphics card, and integrated audio card). When using the same media players on any of the other operating systems (AV Linux 2018, Debian 9.4 Stretch, Windows XP) they do not have this problem, everything runs okay and normal. I would conclude that I am either missing some driver- audio and/or lib package, or their is some kind of flaw in this Fedora 32 operating system, perhaps some kernel upgrade that is incompatible with my older desktop architecture? Upgraded with fresh install from Fedora 27 (with version 27 I had total repositories manually installed into the home directory, no longer available through OS Discs therefore this upgrade involved a live version on thumb drive of Fedora 32 Design Suite). Never had this problem with the clicking noise in the older Fedora 27 operating system.

Anyone able to help me solve this problem?

I have in the past couple of days found another problem, when opening the system settings for sound where you can make adjustments the clicking noise will also start up again until the cable is unplugged for stereo speaker (lime green) external audio jack connector.
Adding this to the list of things that generate the problem I would conclude there is some flaw in the operating system that is causing this problem.

Have tried something else that turned out to be a waste of time.

I deleted the Fedora 32 operating system and then attempted to go back to Fedora 27 since that never had this problem of clicking noise.
Used a DVD I bought from OS Discs with the 11 DVD repositories.
The DVD had the Gnome desktop and tried Rythmbox, no problem with
Fedora 27 and the clicking noise. Tested the same things that were causing problems with 32, internet You Tube music and Fedora operating system sound settings, no problem with clicking noise.
For some reason I could not reinstall manually the Repositories for Fedora 27(a set of 11 DVDs) using the command line, continuously failed to recognize the DVD media when attempting to mount through command line entries along with others to manually install repos into home directory. I have installed manually Fedora 27 and repos on two occasions and they worked on this computer. Is there some reason you cannot go back to an older operating system after installing a newer one with Fedora? This is something that is a problem with Windows operating systems starting with 7.
I bought a set of DVDs through OS Discs and since 27 is obsolete decided the only option to get software packages for this old version would be manually installing repos onto computer.
As a result of failing to get the repos into my home directory I decided “Oh Well” lets try reinstalling 32 over again, maybe the problem will not reoccur. Well I am in the process now of reinstalling everything and first thing I did is try media players and the same problem with the clicking noise continues with Fedora Design Suite 32. If other people are not having this problem I would conclude there is some flaw in the operating system 32, whether a mistake or intentional due to no more support for the type of machine I am using here being the hardware is too old?

I finally decided to re-install Fedora 27 Design Suite and everything works well, no clicking sound. I have installed repos into my home directory and will be able to access older software directly from my private hard drive instead of on-line. Since on-line is up to repositories for Fedora 32 having my setup this way is the best option for older operating system. Unfortunately I could not find a solution to the clicking problem with Fedora 32.
I have another computer that is not as old (only 6 to 7 years instead of 11 to 12) and will not update that one from the current Fedora 30 as a result of this situation. In the future with newer releases of operating systems best to use a live version from usb or DVD and make tests for this problem before any possible installation to desktop hard drive.

Had another serious problem with Fedora 32 that caused me to make this change. For some reason I was locked out of my ability to use any root privileges. Tried a password change application yet did not work, kept asking for a root password when this Fedora 32 does not create a root password during installation and runs similar to Ubuntu using the sudo command for root privilege. Got locked out of the directory and could not use command line to change anything since it kept asking for a root password when I did not have any created as in earlier versions of Fedora when installing os.