Problem installing/booting Fedora KDE spin [intel, nvidia]

I am having a problem after booting live USB with Fedora KDE spin 35/36. Sometimes I am stuck during the loading screen with KDE logo, sometimes after a few seconds on the desktop.
USB is working well - tested on another device.
I didn’t face this problem on other distributions like Manjaro/Ubuntu…
I guess the problem is with compatible hardware.
Current list of HW:

Intel Core i7 8700K @ 3.70GHz
Corsair 16GB KIT DDR4 3000MHz CL15 Vengeance LPX
Micro-Star International Co. Ltd. Z370 TOMAHAWK (MS-7B47) (U3E1)
4095MB NVIDIA GeForce GTX 1080 (MSI)
238GB Apacer AS2280P4 256GB (SSD)

Sounds like it may possibly be related to this?

Are you able to hit Alt+Ctrl+F3 and do a dnf update and reboot and see if that solves the issue since there appear to be relevant fixes since f36 Beta was released.

1 Like

No, that will be a different problem, because @jeyjey says it affects also F35 and not just F36.

@jeyjey Are you saying you only have problems with booting the Fedora KDE Live image from USB, or do you have problems with booting the installed system as well (if you got that far to install it, actually)?

The most likely culprit is probably the opensource nvidia driver nouveau, because nvidia’s linux support is unfortunately terrible. You might find more luck booting the install media in basic graphics mode (in the troubleshooting menu on startup), and then switching to the closed nvidia driver after installation and removing the nomodeset boot option from the grub config. That involves multiple hoops to jump through, unfortunately. When trying this, use the F35 media, because F36 Beta media are a bit broken at this point as in the issue linked above, but should be fixed for the Final image.

Or you can disable/remove the nvidia gpu and install fedora using just the integrated intel gpu. Then enable/put back in the nvidia gpu and install the closed nvidia driver.

You can also try booting GNOME for comparison.


I see you have the nvidia 1080 GPU. There has never been an issue for me with that version of GPU and the nouveau driver while doing an install, though YMMV.

If you can get the install to work and able to boot from the installed F35 then it is very easy to do a dnf system-upgrade process to upgrade from 35 to 36.

I notice from the mobo specs that the RAM is OC at 3000. I wonder if that may have any affect during the initial install?

I also note from the MSI site that that particular mobo has a BIOS update dated Nov 2021 so it may be that a bios update could solve all your issues.

1 Like

After some messing around there are some results:
When BIOS is set to UEFI only and F36 is flashed as GPT (UEFI) via Rufus then KDE is broken.
When BIOS is set to UEFI only and F36 is flashed as GPT (UEFI) via Rufus then GNOME is fine.
When BIOS is set to CSM Bios/Legacy/UEFI and F36 is flashed as MBR via Rufus KDE seems fine (not stuck at least).
→ really similar to the article.

If I install GNOME and then install from terminal KDE environment it’s stuck also after reboot (I have tried only Wayland).
Well, I have no idea what is so much different between KDE and GNOME but it is obvious that KDE has some problems with UEFI.

General info:
BIOS is updated, RAM XAMP mode is OFF.

Problem solved
Just install F35 with the Troubleshooting option and then install Nvidia drivers via Konsole.
F36 is broken even with the Troubleshooting option.

1 Like