Printer prints various symbols


So I been shuffling through various distros and stopped at Fedora as it felt like very professional OS.

Majority stuff works perfect but here’s the printer… It has been added automatically and when I send job to printer it does print, however various symbols only (and 10 pages instead of 1!)

I went to settings and found the printer, noticed no driver was there. So selected database or so called catalog and found my printer (Xerox Workcentre 3225), after selecting printer it does appear full link in the dialog but no OK or SAVE button. Assuming it’s saved I close the window. May worth to point out it the adds underscore to the end of printer name. However when I go to print something the dialog shows the same printer name but without underscore. Even if I remove printer from settings it’s still there when in print dialog.

Having difficult time just to explain it… Help!

What Spin of Fedora are you using? Here is the website for the linux drivers. Drivers & Downloads - WorkCentre 3225 - Linux - Xerox The cups driver never works for me in the Workstation spin, so I have to install the drivers first. Then I go back to the Add Printer and the driver will be included with the huge list of printers available under your printer brand.

1 Like

Hi kulani,

I am using latest Fedora 32 on Lenovo X1 Carbon 3rd gen laptop.

Seems weird that there is driver available and printer is added automatically but it doesn’t work…

I have attached images of what I see in the settings and when in print window. As you see the name of printer is different. The one in settings does not print test page. Print window does seem to send file to print but only prints random symbols.

and second image:

Weird or not, … I don’t know the Xerox, but my “HP” similarly is auto-detected but requires a boost from a separate program, despite the respectable-looking Gnome printer setup box.

Let me say all the steps in one reply. (1) Download the Xerox Linux driver for your printer found at this link Drivers & Downloads - WorkCentre 3225 - Linux - Xerox (2) Open the Downloaded file with an archive application and locate the x86_64 folder. (3) Extract that folder. (4) Double click that extracted folder which is now a .rpm and the Gnome software installer should take over. (5) Do whatever else to complete the install of the Driver. (6) Go back to the add printers. (7) Regardless of what you see, add a new printer (8) Select the Xerox Workcentre 3225 to be added (9) Once it is added, access its profile or whatever (10) Click the button “Select from Database…” (11) Make sure Xerox is selected for the Brand (12) Scroll down the list until you find your printer. (13) If the Drivers installed properly, there should be two option: a cups/driverless option, and the driver you installed (14) Choose the one that is NOT cups (15) Once selected and ok’ed, you will return to the profile page or whatever and the “Driver” will be updated to what you selected. (16) Exit out of the profile (17) Open up a PDF or Word document, and send a test print to the printer. NOTE: Just because the Test print may work from the Printer Settings does not mean it will work for a PDF or Word document, that is why I said to test from those two options. If this does not work, then I have nothing else to say. This is literally how I do it but with a different printer.

Unfortunately there is no file with extension .rpm

Ok. After group installing Fedora Workstation edition onto my laptop, I was able to actually simulate a little of what you are going through. Here are my screen shots of what I did.

This first picture is before the driver install of the printer driver database.

This next picture is me double clicking the zipped file. Then opening the new file in a new window. Then right clicking and opening the file in a terminal. Then typing: ls , to see what is in the file. Then running the install by typing: sudo ./

This is the printer driver database after the install.

If your printer doesn’t work after this, then it isn’t a driver issue. It is a font issue or something else.


Thank you kulani for your suggestion. I have tried as you suggested, only restarted PC after last step, but still had the same issue. I then removed printer from my settings menu and added new printer. This time printer name was different. It prints fine now, however, I now see two printers in my print dialog’s. See below.

The short name printer works fine, however the other one is producing random symbols when printed. How can I permanently disable the other one? I tried removing from settings panel but it comes back automatically. I also noticed the names are different (in one image you can see printer name has underscore at the end of the title)

If one of the added printer prints fine, use it and remove the other. The longer one seems to be the automatically added one for which a wrong driver is probably being used. Good stuff is that you can print on your printer - save the settings for next time (if you needed to reinstall or re-add the printer).

I tried removing it, but it appears again automatically! :sweat_smile:

If you delete the printer that is automatically generated by the operating system, it will just pop back up. Whenever I install Fedora workstation, this happens every time. I have to add a new printer (even thought it is the same one already there), and download a driver from the internet to use for the added printer.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.