Maybe it is solved in the v.3.0, just wondering.

I finally got things to work with the extra lines from this comment: Howdy not working on lockscreen on Fedora 38 · Issue #804 · boltgolt/howdy · GitHub

I’d also suggest adding howdy PAM module to /etc/pam.d/polkit-1 to enable it for “Authentication Required” popups in GNOME.

Ok what a mess. :sweat_smile:

Howdy beta (3.0) is packaged here: principis/howdy-beta Copr

Please completely remove howdy and the non-beta repo before installing this version. You will have issues if you don’t!

If you have any issues related to packaging (missing dependencies, strange errors, …) please post them here, so I can fix them and maybe somewhere in the future include howdy in Fedora. :slight_smile:


  • For pam: pam_python is gone. You have to use /usr/lib64/security/

Thank you a ton! I was waiting this moment since months lol

I successfully unlocked using my face when i typed sudo, in terminal.

I also wanted to make sure lockscreen work, but the instruction in Howdy github and in your repo reference a folder /lib64/security/howdy/ which does not exist for me. In /lib64/security/ I only have a file with a .so extension.

In fact, on my GNOME lockscreen, it says: attemping face recognition but the IR camera is not blinking.

1 Like

You’re welcome. Sorry it had to wait so long.

The documentation I wrote should be correct for the most part, you just have to change /lib64/security/howdy/ to No path required :slightly_smiling_face: .

For example for pam.d/kde

auth       substack     system-auth
auth       sufficient
auth       include      postlogin
account    required

I can’t currently test it for you because I use KDE and time constraints, but it should be something like my example above.

I did that, still the camera does not turn on when on lockscreen. Also it does not turn on when I get the authentication request in popup to unlock keyring or sometimes it appears in terminal.

The usual sudo works


in which one should I add I have already added in gdm-password and sddm. I have GNOME