Prevent suspend when lid close in Fedora 37

Whenever I close my lid, it goes into suspend mode.

I want it should do nothing when I close it.

I have made following changes in sudo vi /etc/systemd/logind.conf


In GNOME Tweaks, ’ Suspend when lid is closed ’ is turned off.

But nothing happened.

1 Like

Added: OK, I see. Strange.

Is that what you want?

I hope that is not what he sees. That image shows suspend is enabled on lid close.

My issue is resoled.

I just ran the following command in terminal -

systemctl mask
1 Like

Thanks, I’ve struggled with the same issue with the exact same initial attempted fixes since installing Fedora on an HP ProBook 4530s. Let’s hope this fixes the problem.

UPDATE: This does indeed solve the problem. Thanks again.