Power Saving Options | Automatic Suspend is on, causes troubles in VM

Problem

In Virtual Machine Manager, the VM gets blacked out and it is written “Display output is not active.”
I tried to activate the screen by moving the mouse, ESC key and
Several keystrokes with the menu above. I had to force switching off.

Cause

The Automatic Suspend is On, switching it off would not block the screen and no “Force off” would be needed.

Graphics:
  Device-1: Red Hat Virtio GPU driver: virtio-pci v: 1
  Display: wayland server: X.Org v: 22.1.8 with: Xwayland v: 22.1.8
    compositor: gnome-shell v: 44.rc driver: dri: swrast gpu: virtio-pci
    resolution: 1224x973~75Hz
  API: OpenGL v: 4.5 Mesa 23.0.0 renderer: llvmpipe (LLVM 15.0.7 256 bits)

Related Issues

Bugzilla report: #NNNN

Workarounds

None yet.
(After installation of F38 in Virtual Machine Manager, switching off the Automatic Suspend manually)

This is by design – at least, when installing not on a virtual machine. For one thing, it’s necessary in order to get the power-consumption scores to acceptable levels to sell in some markets. I think it’s also the right thing to do by default — idle devices use more power than they need to.

Arguably a VM is a special case. But I don’t think that falls under Common Issues, but rather a suggestion for the Workstation Working Group.

There appears to be something wonky with suspend on F38. I haven’t been able to wake my machine from suspend either.
ATM I just have suspend disabled. I’ll file a report as soon as I figure out how to get the report uploader to work :P.

@procyon Are you also using a VM?

I made this request because I remembered to see that several users related suspend problems.
Does it depend on the GPU or the power management? How would I be able to verify this?

No, running HW.

1 Like

First, we’ll likely publish this in Common Issues even though it’s not a bug (it’s an intentional change), because this is very high-profile and many people will likely consider it a bug.

Second, if anyone shows me how to reproduce this issue in a VM (including that it can’t be resumed), I’ll propose it as a blocker bug. In all my testing, my VMs simply ignored the automatic suspend timeout and never suspended.

To reproduce:
I use F37 as Host and made me a F38 VM.
I used settings to display the VM in full screen like described here:

To accelerate the effect it is possible to set the automatic Suspend from 15 to 1 min

Turns out I have to reboot after configuring org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout, not sure why. I can reproduce it now. Great, thanks.

The VM issue is now reported as 2180047 – Automatic suspend also suspends virtual machines, can't be resumed

1 Like

Imho the issue here is not that the automatic suspend is enabled also on VMs, but the fact that you can’t resume them.

1 Like

It is a workaround. And as long we do not know the cause it is in fact a problem. There have been several topics that suspend not works correct. It suspends and gets out of suspend after a second etc.

That’s why I also asked above where we should start to search … power management or GPU/Drivers?

I have documented the overall autosuspend change in:

1 Like

As I understood reading all the additional information Kamil posted is, that the sequence in a virtualization, how to deal with a suspend was wrong.

Instead of Gnome checking if in a VM before initiate a suspend it just suspended the guest what killed it.
Changing the sequence to, if Gnome is a vm don’t suspend, let’s the guest alive. Suspension just should be possible from the Host, right?

1 Like

From the host, it should be like pressing a button on the computer or closing a laptop lid.

This bug is now closed:
https://bugzilla.redhat.com/show_bug.cgi?id=2180047

We no longer need to document it. I’ll close this topic after a week of inactivity.

3 Likes