Plymouth Dual-Boot System with Fedora and Arch

Hello,

I’m currently dual-booting Fedora and Arch Linux on my system. I’ve installed Plymouth on my Arch Linux and it works perfectly when I boot Arch from its own GRUB. However, when I boot Arch from Fedora’s GRUB, Plymouth doesn’t seem to load.

My Fedora’s boot partition and Arch’s root partition are separate, which might be contributing to the issue.

Still, Fedora’s GRUB doesn’t seem to detect Arch’s Plymouth. I’m looking for a way to have Fedora’s GRUB play Arch’s Plymouth video when booting into Arch.

Additionally, I’ve tried using os-prober in Arch’s GRUB to detect Fedora, but it doesn’t seem to detect Fedora. I’ve tried mounting the Fedora partition before running grub-mkconfig, checking the os-prober and grub-mkconfig logs, but that’s a problem for another day.

Any help or suggestions would be greatly appreciated. Thank you!

Look in both the generated grub config files. Find the Arch stanzas and see what is different between them. If you can’t see the differences, post them both here.

Fedora’s grub

BEGIN /etc/grub.d/30_os-prober

    menuentry 'Arch Linux (on /dev/nvme0n1p11)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/vmlinuz-linux-lts--1cd39b35-96c8-4359-a361-0d1eb68c4222' {
            insmod part_gpt
            insmod fat
            search --no-floppy --fs-uuid --set=root DE61-876A
            linux /vmlinuz-linux-lts root=/dev/nvme0n1p11
            initrd /initramfs-linux-lts.img
    }
    menuentry 'Arch Linux (on /dev/nvme0n1p11)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/vmlinuz-linux--1cd39b35-96c8-4359-a361-0d1eb68c4222' {
            insmod part_gpt
            insmod fat
            search --no-floppy --fs-uuid --set=root DE61-876A
            linux /vmlinuz-linux root=/dev/nvme0n1p11
            initrd /initramfs-linux.img
    }

Arch’s grub

BEGIN /etc/grub.d/10_linux

menuentry ‘Arch Linux’ --class arch --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-simple-1cd39b35-96c8-4359-a361-0d1eb68c4222’ {
load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod fat
search --no-floppy --fs-uuid --set=root DE61-876A
echo ‘Loading Linux linux-lts …’
linux /vmlinuz-linux-lts root=UUID=1cd39b35-96c8-4359-a361-0d1eb68c4222 rw loglevel=3 quiet splash udev.log_priority=3 vt.global_cursor_default=1
echo ‘Loading initial ramdisk …’
initrd /initramfs-linux-lts.img
}
submenu ‘Advanced options for Arch Linux’ $menuentry_id_option ‘gnulinux-advanced-1cd39b35-96c8-4359-a361-0d1eb68c4222’ {
menuentry ‘Arch Linux, with Linux linux-lts’ --class arch --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-linux-lts-advanced-1cd39b35-96c8-4359-a361-0d1eb68c4222’ {
load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod fat
search --no-floppy --fs-uuid --set=root DE61-876A
echo ‘Loading Linux linux-lts …’
linux /vmlinuz-linux-lts root=UUID=1cd39b35-96c8-4359-a361-0d1eb68c4222 rw loglevel=3 quiet splash udev.log_priority=3 vt.global_cursor_default=1
echo ‘Loading initial ramdisk …’
initrd /initramfs-linux-lts.img
}
menuentry ‘Arch Linux, with Linux linux-lts (fallback initramfs)’ --class arch --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-linux-lts-fallback-1cd39b35-96c8-4359-a361-0d1eb68c4222’ {
load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod fat
search --no-floppy --fs-uuid --set=root DE61-876A
echo ‘Loading Linux linux-lts …’
linux /vmlinuz-linux-lts root=UUID=1cd39b35-96c8-4359-a361-0d1eb68c4222 rw loglevel=3 quiet splash udev.log_priority=3 vt.global_cursor_default=1
echo ‘Loading initial ramdisk …’
initrd /initramfs-linux-lts-fallback.img
}
menuentry ‘Arch Linux, with Linux linux’ --class arch --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-linux-advanced-1cd39b35-96c8-4359-a361-0d1eb68c4222’ {
load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod fat
search --no-floppy --fs-uuid --set=root DE61-876A
echo ‘Loading Linux linux …’
linux /vmlinuz-linux root=UUID=1cd39b35-96c8-4359-a361-0d1eb68c4222 rw loglevel=3 quiet splash udev.log_priority=3 vt.global_cursor_default=1
echo ‘Loading initial ramdisk …’
initrd /initramfs-linux.img
}
menuentry ‘Arch Linux, with Linux linux (fallback initramfs)’ --class arch --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-linux-fallback-1cd39b35-96c8-4359-a361-0d1eb68c4222’ {
load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod fat
search --no-floppy --fs-uuid --set=root DE61-876A
echo ‘Loading Linux linux …’
linux /vmlinuz-linux root=UUID=1cd39b35-96c8-4359-a361-0d1eb68c4222 rw loglevel=3 quiet splash udev.log_priority=3 vt.global_cursor_default=1
echo ‘Loading initial ramdisk …’
initrd /initramfs-linux-fallback.img
}
}

It is probably because your Fedora entry for Arch is missing quiet.

Yep adding

rw loglevel=3 quiet splash udev.log_priority=3 vt.global_cursor_default=1

solved the problem thanks

1 Like