Please make switching Sound Output device easier

Currently, I need to:

  • click on right end of the top bar
  • choose “Settings”
  • locate Sound
  • locate Output
  • click Output device and choose the correct one

As there is a Sound icon on the top bar, please make it possible to switch output device by either “click” or “right click” on the Sound icon.

Assuming you are using GNOME, there is a slightly easier method. Click the right end of the top bar, then click the right-arrow which is to the right of the output volume slider. It will expand to a list of available output devices.

Thank you for sharing.

As checked, I do not have an right arrow over there.


I have been using workstation for years. As far back as I can remember I have never seen a right-arrow at the end of the volume slider. It might have been there in gnome 3.8 or earlier, but I do not recall seeing it. I certainly have never seen it with gnome 40+.

It’s definitely there for me, it appeared with GNOME 43 (before that I was using an extension to accomplish the same result). I suspect that it supposed to only appear when there are multiple sound output options.

Screenshot from 2023-02-14 09-20-22

1 Like

I used this extension.
This one did the trick for me. Now I don’t know I have this installed or it’s appeared default, but when I get home I’ll check and give feedback.

That’s the one I used too, but it’s not compatible with GNOME 43.

Yeah, now I see, thanks for the info @kpfleming

I have multiple output devices - it is interesting why you got the arrow, but I did not.

Yours looks slightly different in other ways too. Are you using Fedora 37 with GNOME 43, or some other combination?

Interesting that the volume bar at the upper right does that. I had never noted it, and after you said it works that way I tested it. With only one sound output active it does not show the arrow. When I plug in my headphones the arrow shows up and I can select from the normal hdmi output or the headphones. Thanks :+1:

1 Like

I am running Gnome 43.2 w/ Fedora 37 . I do have multiple outputs connected. Still no arrows.



Headphones plugged in.
Screenshot from 2023-02-14 18-59-12
headphones not plugged in.
Screenshot from 2023-02-14 18-59-34

$ screenfetch
           /:-------------:\          USER@mysystem.home.domain
        :-------------------::        OS: Fedora 37 ThirtySeven
      :-----------/shhOHbmp---:\      Kernel: x86_64 Linux 6.1.10-200.fc37.x86_64
    /-----------omMMMNNNMMD  ---:     Uptime: 4d 7h 14m
   :-----------sMMMMNMNMP.    ---:    Packages: 5809
  :-----------:MMMdP-------    ---\   Shell: bash 5.2.15
 ,------------:MMMd--------    ---:   Resolution: 1920x1080
 :------------:MMMd-------    .---:   DE: GNOME 43.2
 :----    oNMMMMMMMMMNho     .----:   WM: Mutter
 :--     .+shhhMMMmhhy++   .------/   WM Theme: 
 :-    -------:MMMd--------------:    GTK Theme: Adwaita [GTK2/3]
 :-   --------/MMMd-------------;     Icon Theme: Adwaita
 :-    ------/hMMMy------------:      Font: Cantarell 14
 :-- :dMNdhhdNMMNo------------;       Disk: 5.0T / 14T (40%)
 :---:sdNMMMMNds:------------:        CPU: AMD Ryzen 5 3600 6-Core @ 12x 3.6GHz
 :------:://:-------------::          GPU: NVIDIA GeForce GTX 1050
 :---------------------://            RAM: 8030MiB / 32019MiB
1 Like

This behavior wasn’t present when F37/GNOME 43 was first released, is there any chance you haven’t applied package updates at all in the last few months?

I update at least once a week.

I figured. No idea why the behavior is so different then.

Suddenly, my Gnome shows the ‘>’, and I can select output devices there.