Plasma translations in other languages?

I only see both American English and British English and that’s all.

Known issue?

1 Like

Good catch! Looks like the translations are not installed. Will look into fixing that.
Thanks for the report!

Edit: This is not the correct solution. Looking into the issue.

While we wait for the server to be back / me setting up a new server, you can overlay the kde-l10n-<your language> package to get translation for your language with:

# Don't do this, this is for KDE4 packages only
$ sudo rpm-ostree install kde-l10n-xyz

Hi, I switched to Kinoite a few days ago, ran into the same issue and tried to figure out what was going on. I noticed this:

~ $ rpm -q --list plasma-discover | grep locale/de

~ $ ll /usr/share/locale/de/LC_MESSAGES/
/usr/bin/ls: cannot access '/usr/share/locale/de/LC_MESSAGES/': No such file or directory

~ [2] $ ll /usr/share/locale/de/LC_MESSAGES/
/usr/bin/ls: cannot access '/usr/share/locale/de/LC_MESSAGES/': No such file or directory

~ [2] $ ll /usr/share/locale/en_GB/LC_MESSAGES/
-rw-r--r--. 4 root root 11K Jan  1  1970 /usr/share/locale/en_GB/LC_MESSAGES/

To me it doesnt look like one individual locale package is missing, but instead rpm decided to filter out the language files for everything != english out at installation time. I found the rpm %_install_langs macro and the install-langs option in the rpm-ostree docs which appear to do exactly that. Maybe one of these leaked into the Kinoite build?

1 Like

Thanks for looking into that! Will take a look.

This should be fixed in the latest update and should not happen with the official builds that are coming in Fedora 35. Let me know how it goes!

In F33 too? And will the localisations will magically install?

Can confirm that it is fixed. Thank you for your work on Kinoite!

1 Like

Yes, this should be fixed in all branches. No need to install anything as this is shipped in the ostree image, which is one of the benefits of ostree/rpm-ostree: when we push a fix, everyone gets it without any action required excepted the update itself.

This is a potential issue in rpm-ostree that I worked around while we figure out the way forward for building Silverblue/Kinoite.

1 Like